aboutsummaryrefslogtreecommitdiff
path: root/www/mod_proxy_xml
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-22 07:50:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-22 07:50:40 +0000
commit45a43fe6fa9db72a4c1a379e8b356caf12db521c (patch)
treec37cb8237c388cb6f9a492f4c397182c3a551326 /www/mod_proxy_xml
parentd095bc77c6ee740dcf8ad07c1b368e6500fe981d (diff)
downloadports-45a43fe6fa9db72a4c1a379e8b356caf12db521c.tar.gz
ports-45a43fe6fa9db72a4c1a379e8b356caf12db521c.zip
mod_proxy_xml is an output filter to rewrite links in a proxy
situation, to ensure that links work for users outside the proxy. It serves the same purpose as Apache's ProxyPassReverse directive does for HTTP headers, and is an essential component of a reverse proxy. WWW: http://apache.webthing.com/mod_proxy_xml/ PR: ports/108053 Submitted by: Dominic Marks <dom at goodforbusiness.co.uk>
Notes
Notes: svn path=/head/; revision=182948
Diffstat (limited to 'www/mod_proxy_xml')
-rw-r--r--www/mod_proxy_xml/Makefile40
-rw-r--r--www/mod_proxy_xml/distinfo6
-rw-r--r--www/mod_proxy_xml/pkg-descr7
-rw-r--r--www/mod_proxy_xml/pkg-plist3
4 files changed, 56 insertions, 0 deletions
diff --git a/www/mod_proxy_xml/Makefile b/www/mod_proxy_xml/Makefile
new file mode 100644
index 000000000000..7b57cc56e6f8
--- /dev/null
+++ b/www/mod_proxy_xml/Makefile
@@ -0,0 +1,40 @@
+# New ports collection Makefile for: mod_proxy_xml
+#
+# Date created: 10/01/2007
+# Whom: Dominic Marks <dom@goodforbusiness.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_proxy_xml
+PORTVERSION= 0.1
+CATEGORIES= www
+MASTER_SITES= http://apache.webthing.com/svn/apache/filters/xmlns/
+DISTFILES= xmlns.h mod_proxy_xml.c
+
+MAINTAINER= dom@helenmarks.co.uk
+COMMENT= Apache module for rewriting URI references in XML
+
+USE_GNOME= libxml2
+USE_APACHE= yes
+WITH_APACHE2= yes
+
+XML2_INC= ${LOCALBASE}/include/libxml2
+XML2_LIB= ${LOCALBASE}/lib
+
+do-extract:
+ @${DO_NADA}
+
+pre-fetch:
+ @${MKDIR} ${WRKDIR}
+
+post-fetch:
+ @${CP} ${DISTDIR}/xmlns.h ${DISTDIR}/mod_proxy_xml.c ${WRKDIR}
+
+do-build:
+ @(cd ${WRKDIR} && ${APXS} -c -I ${XML2_INC} -L ${XML2_LIB} -lxml2 mod_proxy_xml.c)
+
+do-install:
+ @(cd ${WRKDIR} && ${APXS} -A -i mod_proxy_xml.la)
+
+.include <bsd.port.mk>
diff --git a/www/mod_proxy_xml/distinfo b/www/mod_proxy_xml/distinfo
new file mode 100644
index 000000000000..b1866a84e187
--- /dev/null
+++ b/www/mod_proxy_xml/distinfo
@@ -0,0 +1,6 @@
+MD5 (xmlns.h) = 6d3327342b3a996aa6eb9fc77a79de25
+SHA256 (xmlns.h) = ad1a411990601c2b22e5f4d5d071f125d9d484a4fe364d87fb3251de2607490d
+SIZE (xmlns.h) = 5751
+MD5 (mod_proxy_xml.c) = cef3882e5449166e9e82673e41023f1e
+SHA256 (mod_proxy_xml.c) = 91780947448d6da0e03d0db0ace9e4e0376009c644d75cb822ffec1e7711c088
+SIZE (mod_proxy_xml.c) = 11148
diff --git a/www/mod_proxy_xml/pkg-descr b/www/mod_proxy_xml/pkg-descr
new file mode 100644
index 000000000000..e8c6978aebfb
--- /dev/null
+++ b/www/mod_proxy_xml/pkg-descr
@@ -0,0 +1,7 @@
+mod_proxy_xml is an output filter to rewrite links in a proxy
+situation, to ensure that links work for users outside the proxy.
+It serves the same purpose as Apache's ProxyPassReverse directive
+does for HTTP headers, and is an essential component of a reverse
+proxy.
+
+WWW: http://apache.webthing.com/mod_proxy_xml/
diff --git a/www/mod_proxy_xml/pkg-plist b/www/mod_proxy_xml/pkg-plist
new file mode 100644
index 000000000000..bc60954c0c0e
--- /dev/null
+++ b/www/mod_proxy_xml/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache2/mod_proxy_xml.so
+@exec %D/sbin/apxs -e -A -n proxy_xml %D/%F
+@unexec %D/sbin/apxs -e -A -n proxy_xml %D/%F