aboutsummaryrefslogtreecommitdiff
path: root/www/mod_put/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-07 13:13:48 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-07 13:13:48 +0000
commit6988580bcb421c37d687578fbde71bb0b2c683a3 (patch)
treef893fc90e5f7cd3f939711beb6562bf6128c0cb3 /www/mod_put/Makefile
parent9343cbc6fdf97cd0b5933ee7dab00e637b04297c (diff)
downloadports-6988580bcb421c37d687578fbde71bb0b2c683a3.tar.gz
ports-6988580bcb421c37d687578fbde71bb0b2c683a3.zip
add mod_put
An Apache module that provides PUT and DELETE methods PR: 28414 Submitted by: Joao Carlos Mendes Luis <jonny@jonny.eng.br>
Notes
Notes: svn path=/head/; revision=44872
Diffstat (limited to 'www/mod_put/Makefile')
-rw-r--r--www/mod_put/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/mod_put/Makefile b/www/mod_put/Makefile
new file mode 100644
index 000000000000..31217ddb2d48
--- /dev/null
+++ b/www/mod_put/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mod_put Apache module
+# Date created: Jun 26 2001
+# Whom: Joao Carlos Mendes Luis <jonny@jonny.eng.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_put
+PORTVERSION= 1.3
+CATEGORIES= www
+MASTER_SITES= http://hpwww.ec-lyon.fr/~vincent/apache/
+DISTFILES= mod_put.tar.gz
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+do-build:
+ cd ${WRKSRC} && ${LOCALBASE}/sbin/apxs -c ${PORTNAME}.c
+
+do-install:
+ cd ${WRKSRC} && ${LOCALBASE}/sbin/apxs -A -i ${PORTNAME}.so
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.html \
+ ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>