aboutsummaryrefslogtreecommitdiff
path: root/www/mod_setenvifplus/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-08-21 18:37:48 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-08-21 18:37:48 +0000
commit0eeea5a293f9be2eec53d599ba4e608b4d0f4328 (patch)
treeb6e7842d607bb1941b55ba0f542571410dbc44a9 /www/mod_setenvifplus/Makefile
parent06e6ff3128cb562e5b9783d72c1d933db92d864e (diff)
downloadports-0eeea5a293f9be2eec53d599ba4e608b4d0f4328.tar.gz
ports-0eeea5a293f9be2eec53d599ba4e608b4d0f4328.zip
The mod_setenvifplus module allows you to set environment variables
according to whether different aspects of the request match regular expressions you specify. These environment variables can be used by other parts of the server to make decisions about actions to be taken, e.g. by using mod_qos or to propagate supplemental information to the appliaction via HTTP header data. mod_setenvifplus is derived from the standard Apache modules mod_setenvif and mod_headers. WWW: http://modsetenvifplus.sourceforge.net/ PR: ports/158709 Submitted by: Jim Riggs <ports at christianserving.org>
Notes
Notes: svn path=/head/; revision=280130
Diffstat (limited to 'www/mod_setenvifplus/Makefile')
-rw-r--r--www/mod_setenvifplus/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/www/mod_setenvifplus/Makefile b/www/mod_setenvifplus/Makefile
new file mode 100644
index 000000000000..a77fc1d8a611
--- /dev/null
+++ b/www/mod_setenvifplus/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mod_setenvifplus
+# Date created: 2010-11-29
+# Whom: Jim Riggs <ports@christianserving.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_setenvifplus
+PORTVERSION= 0.12
+CATEGORIES= www
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= modsetenvifplus
+EXTRACT_SUFX= -src.tar.gz
+
+MAINTAINER= ports@christianserving.org
+COMMENT= Allows setting environment variables based on request attributes
+
+LICENSE= ASL
+
+USE_APACHE= 20+
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+SRC_FILE= ${WRKSRC}/apache2/${MODULENAME}.c
+
+.include <bsd.port.mk>