aboutsummaryrefslogtreecommitdiff
path: root/www/moodle310
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2020-11-09 11:47:00 +0000
committerWen Heping <wen@FreeBSD.org>2020-11-09 11:47:00 +0000
commit2f065d17a6a07b8a3c650dcc6b0a153f231d6bc6 (patch)
treed2a58fe38edf4748cd107a2211c6f6489b06c62b /www/moodle310
parent49df30da4850bd99a9cf75af3a27a0da2be6c62f (diff)
downloadports-2f065d17a6a07b8a3c650dcc6b0a153f231d6bc6.tar.gz
ports-2f065d17a6a07b8a3c650dcc6b0a153f231d6bc6.zip
- Repocopy www/moodle39 --> www/moodle310 and update to 3.10
Notes
Notes: svn path=/head/; revision=554712
Diffstat (limited to 'www/moodle310')
-rw-r--r--www/moodle310/Makefile62
-rw-r--r--www/moodle310/distinfo3
-rw-r--r--www/moodle310/files/pkg-message.in59
-rw-r--r--www/moodle310/pkg-descr7
4 files changed, 131 insertions, 0 deletions
diff --git a/www/moodle310/Makefile b/www/moodle310/Makefile
new file mode 100644
index 000000000000..54f460428b7a
--- /dev/null
+++ b/www/moodle310/Makefile
@@ -0,0 +1,62 @@
+# Created by: Javier Martin Rueda <jmrueda@diatel.upm.es>
+# $FreeBSD$
+
+PORTNAME= moodle
+PORTVERSION= 3.10
+CATEGORIES= www
+MASTER_SITES= SF/moodle/Moodle/stable310/
+PKGNAMESUFFIX= ${PKGORIGIN:T:S/moodle//}${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Course management system based on social constructionism
+
+LICENSE= GPLv3
+
+CONFLICTS= moodle35-3.5.[0-9]* moodle37-3.7.[0-9]* moodle38-3.8.[0-9]* \
+ moodle39-3.9.[0-9]*
+
+USES= cpe php:flavors tar:tgz
+USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
+ opcache openssl pcre session simplexml soap spl tokenizer \
+ xml xmlreader xmlrpc zip zlib
+WRKSRC= ${WRKDIR}/moodle
+
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= MYSQL PGSQL MSSQL
+OPTIONS_DEFINE= LDAP
+OPTIONS_DEFAULT= MYSQL
+
+MYSQL_USES= mysql
+MYSQL_USE= php=mysqli
+PGSQL_USE= php=pgsql
+MSSQL_USE= php=mssql
+LDAP_USE= php=ldap
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
+
+MOODLEDIR?= www/moodle
+MOODLEDATADIR?= moodledata
+
+pre-install:
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
+ @${ECHO_CMD} "@mode 755" >> ${PLIST}
+ @${ECHO} @dir ${MOODLEDATADIR} >> ${PLIST}
+ @${ECHO_CMD} "@mode" >> ${PLIST}
+ @${ECHO_CMD} "@group" >> ${PLIST}
+ @${ECHO_CMD} "@owner" >> ${PLIST}
+
+# Here for safety I do not set moodle diretory 0755 permission
+# It require user write config.php manually then.
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >>${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dir ${MOODLEDIR}?g" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${MOODLEDIR}
+ @${INSTALL} -d ${STAGEDIR}${PREFIX}/${MOODLEDATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/moodle310/distinfo b/www/moodle310/distinfo
new file mode 100644
index 000000000000..89aa213ef3fd
--- /dev/null
+++ b/www/moodle310/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1604948979
+SHA256 (moodle-3.10.tgz) = e1a60a6665f29b54eaff8eb63c88096f8b071947251245343a4d62409eaed1ac
+SIZE (moodle-3.10.tgz) = 57423153
diff --git a/www/moodle310/files/pkg-message.in b/www/moodle310/files/pkg-message.in
new file mode 100644
index 000000000000..b17b53d32fdb
--- /dev/null
+++ b/www/moodle310/files/pkg-message.in
@@ -0,0 +1,59 @@
+[
+{ type: install
+ message: <<EOM
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
+
+2) Add the following to your Apache configuration file
+ httpd.conf, and restart the server:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%/>
+ AllowOverride None
+ Require all granted
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to invoke the file admin/cron.php
+ every five minutes or so. For instance:
+ */5 * * * * fetch http://your.server.com/moodle/admin/cron.php
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+EOM
+}
+{ type: upgrade
+ message: <<EOM
+If you are upgrading from an earlier version of Moodle, check out
+possible additional steps at:
+
+ https://docs.moodle.org/37/en/Upgrading
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
+EOM
+}
+]
diff --git a/www/moodle310/pkg-descr b/www/moodle310/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle310/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/