aboutsummaryrefslogtreecommitdiff
path: root/www/mozplugger
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-02-25 16:14:28 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-02-25 16:14:28 +0000
commit7121f8f69fb5517ed7097f858acf26731c8cc098 (patch)
treeda1d13baef9fb7bb531693021fe95b2a64d6cd52 /www/mozplugger
parent4b1f4956d6c59fec30673e3378fddc49ab29b67e (diff)
downloadports-7121f8f69fb5517ed7097f858acf26731c8cc098.tar.gz
ports-7121f8f69fb5517ed7097f858acf26731c8cc098.zip
- Update to 2.1.3
- Trim header PR: ports/176384 Submitted by: Rusty Nejdl <rnejdl@ringofsaturn.com> (maintainer)
Notes
Notes: svn path=/head/; revision=312929
Diffstat (limited to 'www/mozplugger')
-rw-r--r--www/mozplugger/Makefile3
-rw-r--r--www/mozplugger/distinfo4
-rw-r--r--www/mozplugger/files/patch-Makefile.in54
-rw-r--r--www/mozplugger/pkg-plist1
4 files changed, 28 insertions, 34 deletions
diff --git a/www/mozplugger/Makefile b/www/mozplugger/Makefile
index 66500887028d..ae6d1dc162b7 100644
--- a/www/mozplugger/Makefile
+++ b/www/mozplugger/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mozplugger
-PORTVERSION= 1.14.6
+PORTVERSION= 2.1.3
CATEGORIES= www
MASTER_SITES= http://mozplugger.mozdev.org/files/
@@ -11,6 +11,7 @@ COMMENT= Framework for loading web content in external viewers
GNU_CONFIGURE= yes
USE_XORG= x11 xt
+USE_GMAKE= yes
MAN7= mozplugger.7
SUB_FILES= pkg-message
diff --git a/www/mozplugger/distinfo b/www/mozplugger/distinfo
index 2e7a8f476a8d..96d671fc2a93 100644
--- a/www/mozplugger/distinfo
+++ b/www/mozplugger/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mozplugger-1.14.6.tar.gz) = 3fd73b51d1c0b1c310cecac90155a86ef59c748dff677df542e39282ea7ecba7
-SIZE (mozplugger-1.14.6.tar.gz) = 140735
+SHA256 (mozplugger-2.1.3.tar.gz) = d19b6063d0aba87430e5ce2e3a4230807288eb45acec1d412009c7f530d8b30a
+SIZE (mozplugger-2.1.3.tar.gz) = 153715
diff --git a/www/mozplugger/files/patch-Makefile.in b/www/mozplugger/files/patch-Makefile.in
index 3b8d05f612f6..dbc4c059bdbf 100644
--- a/www/mozplugger/files/patch-Makefile.in
+++ b/www/mozplugger/files/patch-Makefile.in
@@ -1,44 +1,36 @@
---- Makefile.in.orig 2012-09-26 15:43:37.000000000 -0500
-+++ Makefile.in 2012-09-26 15:46:01.000000000 -0500
-@@ -22,7 +22,7 @@
+--- Makefile.in.orig 2013-02-23 16:46:10.000000000 -0600
++++ Makefile.in 2013-02-23 16:48:17.000000000 -0600
+@@ -37,7 +37,7 @@
RPMDIR=/usr/src/RPM
- # Choose compiler
+ # Choose tool set
-CC=@CC@
+CC?=@CC@
- MKDIR=mkdir -p
-
- SOURCE_FILES=mozplugger.c \
-@@ -161,21 +161,20 @@
+ LD=@CC@
+ MKDEP=@CC@ -MM
+ BIN2O=@BIN2O@
+@@ -267,12 +267,12 @@
install:
- -@install -d @bindir@
-- -@install -d $(prefix)$(libprefix)/mozilla/plugins
-+ -@install -d $(root)${WEBPLUGINS_DIR}
- -@install -d @mandir@/man7
- -@install -d @sysconfdir@
- install mozplugger-helper @bindir@
+ -install -d @bindir@
++ -install -d $(root)${WEBPLUGINS_DIR}
+ install mozplugger-helper @bindir@
install mozplugger-controller @bindir@
- install mozplugger-linker @bindir@
+ install mozplugger-linker @bindir@
+ install mozplugger-update @bindir@
+- -for a in ${PLUGINDIRS}; do install -d $$a ; done
- for a in ${PLUGINDIRS}; do install mozplugger.so $$a ; done
--# cp mozplugger.so $(prefix)$(libprefix)/mozilla/plugins/
+ cp mozplugger.so $(root)${WEBPLUGINS_DIR}
- install $(srcdir)/mozpluggerrc @sysconfdir@
- install $(srcdir)/mozplugger.7 @mandir@/man7/
-
+ -install -d @sysconfdir@
+ install $(srcdir)/mozpluggerrc @sysconfdir@
+ -install -d @mandir@/man7
+@@ -281,7 +281,8 @@
uninstall:
- rm -f @mandir@/man7/mozplugger.7
- rm -f @sysconfdir@/mozpluggerrc
-- for target in ${PLUGINDIRS}; do rm -f $${target}/mozplugger.so; done
+ -rm -f @sysconfdir@/mozpluggerrc
+ -rmdir @sysconfdir@
+- -for a in ${PLUGINDIRS}; do rm -f $$a/mozplugger.so ; done
++ rm -f $(root)${WEBPLUGINS_DIR}/mozplugger.so
+ rm -f $(root)${WEBPLUGINS_DIR}/mozplugger.so
- rm -f @bindir@/mozplugger-linker
- rm -f @bindir@/mozplugger-controller
- rm -f @bindir@/mozplugger-helper
-@@ -183,6 +182,7 @@
+ -rm -f @mandir@/man7/mozplugger.7
-rmdir @mandir@/man7
-rmdir @mandir@
- -rmdir @bindir@
-+ -rmdir $(root)${WEBPLUGINS_DIR}
-
- MOZ_PACKAGE=mozplugger-@PACKAGE_VERSION@
-
diff --git a/www/mozplugger/pkg-plist b/www/mozplugger/pkg-plist
index a82f152c6df4..0b6ecf63bdb7 100644
--- a/www/mozplugger/pkg-plist
+++ b/www/mozplugger/pkg-plist
@@ -1,6 +1,7 @@
bin/mozplugger-controller
bin/mozplugger-helper
bin/mozplugger-linker
+bin/mozplugger-update
etc/mozpluggerrc
%%WEBPLUGINS_DIR%%/mozplugger.so
@dirrmtry %%WEBPLUGINS_DIR%%