aboutsummaryrefslogtreecommitdiff
path: root/www/mybb/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-05 17:00:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-05 17:00:00 +0000
commit7115b47749b8cb4118f266c5d14e85fe0ed0b803 (patch)
tree8b6e6e8fbbccaee69a1a3a0ce52731d008eb23b4 /www/mybb/Makefile
parent796de5c241060bc793f25e0fa8b45c7f7061fdc3 (diff)
downloadports-7115b47749b8cb4118f266c5d14e85fe0ed0b803.tar.gz
ports-7115b47749b8cb4118f266c5d14e85fe0ed0b803.zip
- Stage support
Notes
Notes: svn path=/head/; revision=342778
Diffstat (limited to 'www/mybb/Makefile')
-rw-r--r--www/mybb/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/www/mybb/Makefile b/www/mybb/Makefile
index 81033f416427..c1b388d22f18 100644
--- a/www/mybb/Makefile
+++ b/www/mybb/Makefile
@@ -19,15 +19,13 @@ USE_MYSQL= yes
SUB_FILES= pkg-message
WWWDIR?= ${PREFIX}/www/${PORTNAME}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
do-install:
- @${MKDIR} ${WWWDIR}
- ${CP} -R ${WRKSRC}/ ${WWWDIR}
- ${TOUCH} ${WWWDIR}/inc/config.php
- @${CHOWN} ${WWWOWN} ${WWWDIR}/inc/config.php ${WWWDIR}/inc/settings.php
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ ${CP} -R ${WRKSRC}/ ${STAGEDIR}${WWWDIR}
+ ${TOUCH} ${STAGEDIR}${WWWDIR}/inc/config.php
+ @${CHOWN} ${WWWOWN} ${STAGEDIR}${WWWDIR}/inc/config.php ${STAGEDIR}${WWWDIR}/inc/settings.php
create-plist:
@${FIND} -s ${WRKSRC}/${file} -not -type d \