aboutsummaryrefslogtreecommitdiff
path: root/www/nextcloud-contacts
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-11-24 23:45:17 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-11-24 23:45:17 +0000
commit4f058f1319d292c1d2fa443381d3b0557b5e313b (patch)
tree2c763694193e043351a70a9bab22df465c939907 /www/nextcloud-contacts
parentae9f040b69a846aad201a352c5b438e7dde4fbad (diff)
downloadports-4f058f1319d292c1d2fa443381d3b0557b5e313b.tar.gz
ports-4f058f1319d292c1d2fa443381d3b0557b5e313b.zip
www/nextcloud: Add essential apps
Notes
Notes: svn path=/head/; revision=454858
Diffstat (limited to 'www/nextcloud-contacts')
-rw-r--r--www/nextcloud-contacts/Makefile35
-rw-r--r--www/nextcloud-contacts/distinfo3
-rw-r--r--www/nextcloud-contacts/pkg-descr11
-rw-r--r--www/nextcloud-contacts/pkg-plist179
4 files changed, 228 insertions, 0 deletions
diff --git a/www/nextcloud-contacts/Makefile b/www/nextcloud-contacts/Makefile
new file mode 100644
index 000000000000..9f25c2e90a4d
--- /dev/null
+++ b/www/nextcloud-contacts/Makefile
@@ -0,0 +1,35 @@
+# Created by: Bernard Spil <brnrd@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= contacts
+PORTVERSION= 2.0.1
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+MASTER_SITES= https://github.com/${PKGNAMEPREFIX:S/-//}/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
+PKGNAMEPREFIX= nextcloud-
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}/${DISTNAME}-${DISTVERSIONPREFIX}${PORTVERSION}
+
+MAINTAINER= brnrd@freebsd.org
+COMMENT= Contacts app for Nextcloud
+
+LICENSE= AGPLv3
+
+RUN_DEPENDS= nextcloud>=12:www/nextcloud
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+NEXTCLOUD_USERNAME?= ${WWWOWN}
+NEXTCLOUD_GROUPNAME?= ${WWWGRP}
+
+PLIST_SUB= NEXTCLOUD_USERNAME=${NEXTCLOUD_USERNAME} \
+ NEXTCLOUD_GROUPNAME=${NEXTCLOUD_GROUPNAME}
+
+WWWDIR= ${PREFIX}/www/nextcloud/apps/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>
diff --git a/www/nextcloud-contacts/distinfo b/www/nextcloud-contacts/distinfo
new file mode 100644
index 000000000000..1d1b25faca3b
--- /dev/null
+++ b/www/nextcloud-contacts/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511565486
+SHA256 (nextcloud/contacts-v2.0.1/contacts.tar.gz) = ce17a7dde519698abb86be987d803913222c6691bf297a1082001344031fd2d9
+SIZE (nextcloud/contacts-v2.0.1/contacts.tar.gz) = 652600
diff --git a/www/nextcloud-contacts/pkg-descr b/www/nextcloud-contacts/pkg-descr
new file mode 100644
index 000000000000..a0b3a01f16cf
--- /dev/null
+++ b/www/nextcloud-contacts/pkg-descr
@@ -0,0 +1,11 @@
+The Nextcloud contacts app is a user interface for Nextcloud's CardDAV
+server. Easily sync contacts from various devices with your Nextcloud
+and edit them online.
+ * Integration with other Nextcloud apps! Currently Mail and Calendar -
+ more to come.
+ * Never forget a birthday! You can sync birthdays and other recurring
+ events with your Nextcloud Calendar.
+ * Sharing of Adressbooks! You want to share your contacts with your
+ friends or coworkers? No problem!
+ * We're not reinventing the wheel! Based on the great and open SabreDAV
+ library.
diff --git a/www/nextcloud-contacts/pkg-plist b/www/nextcloud-contacts/pkg-plist
new file mode 100644
index 000000000000..d4fb17edf789
--- /dev/null
+++ b/www/nextcloud-contacts/pkg-plist
@@ -0,0 +1,179 @@
+@owner %%NEXTCLOUD_USERNAME%%
+@group %%NEXTCLOUD_GROUPNAME%%
+%%WWWDIR%%/appinfo/app.php
+%%WWWDIR%%/appinfo/info.xml
+%%WWWDIR%%/appinfo/routes.php
+%%WWWDIR%%/css/_animations.scss
+%%WWWDIR%%/css/_app-content-list.scss
+%%WWWDIR%%/css/_contactlist.scss
+%%WWWDIR%%/css/_details.scss
+%%WWWDIR%%/css/_navigation.scss
+%%WWWDIR%%/css/_settings.scss
+%%WWWDIR%%/css/style.css
+%%WWWDIR%%/css/style.scss
+%%WWWDIR%%/img/app.png
+%%WWWDIR%%/img/app.svg
+%%WWWDIR%%/img/favicon-mask.svg
+%%WWWDIR%%/img/favicon-touch.png
+%%WWWDIR%%/img/favicon-touch.svg
+%%WWWDIR%%/img/favicon.ico
+%%WWWDIR%%/img/favicon.png
+%%WWWDIR%%/img/favicon.svg
+%%WWWDIR%%/img/group.svg
+%%WWWDIR%%/js/dav/dav.js
+%%WWWDIR%%/js/public/script.js
+%%WWWDIR%%/js/vendor/angular-bootstrap/ui-bootstrap-tpls.min.js
+%%WWWDIR%%/js/vendor/angular-bootstrap/ui-bootstrap.min.js
+%%WWWDIR%%/js/vendor/angular-cache/dist/angular-cache.js
+%%WWWDIR%%/js/vendor/angular-click-outside/clickoutside.directive.js
+%%WWWDIR%%/js/vendor/angular-route/angular-route.js
+%%WWWDIR%%/js/vendor/angular-sanitize/angular-sanitize.js
+%%WWWDIR%%/js/vendor/angular-uuid4/angular-uuid4.js
+%%WWWDIR%%/js/vendor/angular/angular.js
+%%WWWDIR%%/js/vendor/jquery-timepicker/jquery.ui.timepicker.js
+%%WWWDIR%%/js/vendor/ngclipboard/dist/ngclipboard.min.js
+%%WWWDIR%%/js/vendor/ui-select/dist/select.js
+%%WWWDIR%%/js/vendor/vcard/src/vcard.js
+%%WWWDIR%%/l10n/.tx/config
+%%WWWDIR%%/l10n/af.js
+%%WWWDIR%%/l10n/af.json
+%%WWWDIR%%/l10n/ar.js
+%%WWWDIR%%/l10n/ar.json
+%%WWWDIR%%/l10n/ast.js
+%%WWWDIR%%/l10n/ast.json
+%%WWWDIR%%/l10n/bg.js
+%%WWWDIR%%/l10n/bg.json
+%%WWWDIR%%/l10n/bn_BD.js
+%%WWWDIR%%/l10n/bn_BD.json
+%%WWWDIR%%/l10n/bs.js
+%%WWWDIR%%/l10n/bs.json
+%%WWWDIR%%/l10n/ca.js
+%%WWWDIR%%/l10n/ca.json
+%%WWWDIR%%/l10n/cs.js
+%%WWWDIR%%/l10n/cs.json
+%%WWWDIR%%/l10n/da.js
+%%WWWDIR%%/l10n/da.json
+%%WWWDIR%%/l10n/de.js
+%%WWWDIR%%/l10n/de.json
+%%WWWDIR%%/l10n/de_DE.js
+%%WWWDIR%%/l10n/de_DE.json
+%%WWWDIR%%/l10n/el.js
+%%WWWDIR%%/l10n/el.json
+%%WWWDIR%%/l10n/en_GB.js
+%%WWWDIR%%/l10n/en_GB.json
+%%WWWDIR%%/l10n/eo.js
+%%WWWDIR%%/l10n/eo.json
+%%WWWDIR%%/l10n/es.js
+%%WWWDIR%%/l10n/es.json
+%%WWWDIR%%/l10n/es_AR.js
+%%WWWDIR%%/l10n/es_AR.json
+%%WWWDIR%%/l10n/es_MX.js
+%%WWWDIR%%/l10n/es_MX.json
+%%WWWDIR%%/l10n/et_EE.js
+%%WWWDIR%%/l10n/et_EE.json
+%%WWWDIR%%/l10n/eu.js
+%%WWWDIR%%/l10n/eu.json
+%%WWWDIR%%/l10n/fa.js
+%%WWWDIR%%/l10n/fa.json
+%%WWWDIR%%/l10n/fi.js
+%%WWWDIR%%/l10n/fi.json
+%%WWWDIR%%/l10n/fr.js
+%%WWWDIR%%/l10n/fr.json
+%%WWWDIR%%/l10n/he.js
+%%WWWDIR%%/l10n/he.json
+%%WWWDIR%%/l10n/hr.js
+%%WWWDIR%%/l10n/hr.json
+%%WWWDIR%%/l10n/hu.js
+%%WWWDIR%%/l10n/hu.json
+%%WWWDIR%%/l10n/ia.js
+%%WWWDIR%%/l10n/ia.json
+%%WWWDIR%%/l10n/id.js
+%%WWWDIR%%/l10n/id.json
+%%WWWDIR%%/l10n/is.js
+%%WWWDIR%%/l10n/is.json
+%%WWWDIR%%/l10n/it.js
+%%WWWDIR%%/l10n/it.json
+%%WWWDIR%%/l10n/ja.js
+%%WWWDIR%%/l10n/ja.json
+%%WWWDIR%%/l10n/ka_GE.js
+%%WWWDIR%%/l10n/ka_GE.json
+%%WWWDIR%%/l10n/ko.js
+%%WWWDIR%%/l10n/ko.json
+%%WWWDIR%%/l10n/lt_LT.js
+%%WWWDIR%%/l10n/lt_LT.json
+%%WWWDIR%%/l10n/lv.js
+%%WWWDIR%%/l10n/lv.json
+%%WWWDIR%%/l10n/mk.js
+%%WWWDIR%%/l10n/mk.json
+%%WWWDIR%%/l10n/mn.js
+%%WWWDIR%%/l10n/mn.json
+%%WWWDIR%%/l10n/nb.js
+%%WWWDIR%%/l10n/nb.json
+%%WWWDIR%%/l10n/nl.js
+%%WWWDIR%%/l10n/nl.json
+%%WWWDIR%%/l10n/nn_NO.js
+%%WWWDIR%%/l10n/nn_NO.json
+%%WWWDIR%%/l10n/no-php
+%%WWWDIR%%/l10n/oc.js
+%%WWWDIR%%/l10n/oc.json
+%%WWWDIR%%/l10n/pl.js
+%%WWWDIR%%/l10n/pl.json
+%%WWWDIR%%/l10n/pt_BR.js
+%%WWWDIR%%/l10n/pt_BR.json
+%%WWWDIR%%/l10n/pt_PT.js
+%%WWWDIR%%/l10n/pt_PT.json
+%%WWWDIR%%/l10n/ro.js
+%%WWWDIR%%/l10n/ro.json
+%%WWWDIR%%/l10n/ru.js
+%%WWWDIR%%/l10n/ru.json
+%%WWWDIR%%/l10n/sk.js
+%%WWWDIR%%/l10n/sk.json
+%%WWWDIR%%/l10n/sl.js
+%%WWWDIR%%/l10n/sl.json
+%%WWWDIR%%/l10n/sq.js
+%%WWWDIR%%/l10n/sq.json
+%%WWWDIR%%/l10n/sr.js
+%%WWWDIR%%/l10n/sr.json
+%%WWWDIR%%/l10n/sv.js
+%%WWWDIR%%/l10n/sv.json
+%%WWWDIR%%/l10n/ta_LK.js
+%%WWWDIR%%/l10n/ta_LK.json
+%%WWWDIR%%/l10n/th.js
+%%WWWDIR%%/l10n/th.json
+%%WWWDIR%%/l10n/tr.js
+%%WWWDIR%%/l10n/tr.json
+%%WWWDIR%%/l10n/uk.js
+%%WWWDIR%%/l10n/uk.json
+%%WWWDIR%%/l10n/vi.js
+%%WWWDIR%%/l10n/vi.json
+%%WWWDIR%%/l10n/zh_CN.js
+%%WWWDIR%%/l10n/zh_CN.json
+%%WWWDIR%%/l10n/zh_TW.js
+%%WWWDIR%%/l10n/zh_TW.json
+%%WWWDIR%%/lib/ContactsMenu/Providers/DetailsProvider.php
+%%WWWDIR%%/lib/Controller/PageController.php
+%%WWWDIR%%/templates/addressBook.html
+%%WWWDIR%%/templates/addressBookList.html
+%%WWWDIR%%/templates/avatar.html
+%%WWWDIR%%/templates/contact.html
+%%WWWDIR%%/templates/contactDetails.html
+%%WWWDIR%%/templates/contactImport.html
+%%WWWDIR%%/templates/contactList.html
+%%WWWDIR%%/templates/detailItems/adr.html
+%%WWWDIR%%/templates/detailItems/date.html
+%%WWWDIR%%/templates/detailItems/email.html
+%%WWWDIR%%/templates/detailItems/groups.html
+%%WWWDIR%%/templates/detailItems/hidden.html
+%%WWWDIR%%/templates/detailItems/n.html
+%%WWWDIR%%/templates/detailItems/select.html
+%%WWWDIR%%/templates/detailItems/tel.html
+%%WWWDIR%%/templates/detailItems/text.html
+%%WWWDIR%%/templates/detailItems/textarea.html
+%%WWWDIR%%/templates/detailItems/url.html
+%%WWWDIR%%/templates/detailItems/username.html
+%%WWWDIR%%/templates/group.html
+%%WWWDIR%%/templates/groupList.html
+%%WWWDIR%%/templates/importScreen.html
+%%WWWDIR%%/templates/main.php
+%%WWWDIR%%/templates/newContactButton.html
+%%WWWDIR%%/templates/sortBy.html