aboutsummaryrefslogtreecommitdiff
path: root/www/nextcloud-tasks/Makefile
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-12-06 12:49:51 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-12-06 12:49:51 +0000
commit4d49bc10fc8ee8e0e663949db98d8ade7ec1c7c1 (patch)
tree3b1b354559423ab03159a3b68aabc7be6f518447 /www/nextcloud-tasks/Makefile
parentb6be012a4685c57d5fd44da6e9a5126a70263f6f (diff)
downloadports-4d49bc10fc8ee8e0e663949db98d8ade7ec1c7c1.tar.gz
ports-4d49bc10fc8ee8e0e663949db98d8ade7ec1c7c1.zip
www/nextcloud-tasks: Add new Tasks Nextcloud app
Notes
Notes: svn path=/head/; revision=455648
Diffstat (limited to 'www/nextcloud-tasks/Makefile')
-rw-r--r--www/nextcloud-tasks/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/nextcloud-tasks/Makefile b/www/nextcloud-tasks/Makefile
new file mode 100644
index 000000000000..6ade57162f96
--- /dev/null
+++ b/www/nextcloud-tasks/Makefile
@@ -0,0 +1,35 @@
+# Created by: Bernard Spil <brnrd@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= tasks
+PORTVERSION= 0.9.5
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+MASTER_SITES= https://github.com/${PKGNAMEPREFIX:S/-//}/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
+PKGNAMEPREFIX= nextcloud-
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}/${DISTNAME}-${DISTVERSIONPREFIX}${PORTVERSION}
+
+MAINTAINER= brnrd@freebsd.org
+COMMENT= Tasks app for Nextcloud
+
+LICENSE= AGPLv3
+
+RUN_DEPENDS= nextcloud>=12:www/nextcloud
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+NEXTCLOUD_USERNAME?= ${WWWOWN}
+NEXTCLOUD_GROUPNAME?= ${WWWGRP}
+
+PLIST_SUB= NEXTCLOUD_USERNAME=${NEXTCLOUD_USERNAME} \
+ NEXTCLOUD_GROUPNAME=${NEXTCLOUD_GROUPNAME}
+
+WWWDIR= ${PREFIX}/www/nextcloud/apps/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>