aboutsummaryrefslogtreecommitdiff
path: root/www/nghttp2/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-17 18:02:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-17 18:02:01 +0000
commit817ec5bcf3bc501238c83a4f4feb8bf0cecea9ed (patch)
tree10d257d849af7e69eb148069927c4d85b7076912 /www/nghttp2/Makefile
parente99ca0001adb2f9ec7aa2e0ace7c489b5923af1e (diff)
downloadports-817ec5bcf3bc501238c83a4f4feb8bf0cecea9ed.tar.gz
ports-817ec5bcf3bc501238c83a4f4feb8bf0cecea9ed.zip
Remoce USES=autoreconf
It is not needed after switching to upstream release tarball (r547037).
Notes
Notes: svn path=/head/; revision=565554
Diffstat (limited to 'www/nghttp2/Makefile')
-rw-r--r--www/nghttp2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 890dd30bda93..83aedc8cae11 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -20,7 +20,7 @@ OPTIONS_DEFAULT=APP HPACK
OPTIONS_SUB= yes
APP_DESC= Build h2load, nghttp, nghttpd and nghttpx
-USES= autoreconf compiler:c++14-lang gmake libtool localbase pathfix pkgconfig ssl tar:xz
+USES= compiler:c++14-lang gmake libtool localbase pathfix pkgconfig ssl tar:xz
CONFIGURE_ARGS= --disable-python-bindings --with-jemalloc
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
@@ -55,8 +55,8 @@ HPACK_CONFIGURE_ENABLE= hpack-tools
HPACK_LIB_DEPENDS= libjansson.so:devel/jansson
post-patch:
- @${REINPLACE_CMD} -e '/^SUBDIRS = / s| lib||' ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e 's|$$[({]top_builddir[})]/lib/libnghttp2.la|-lnghttp2|' ${WRKSRC}/*/Makefile.am
+ @${REINPLACE_CMD} -e '/^SUBDIRS = / s| lib||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|$$[({]top_builddir[})]/lib/libnghttp2.la|-lnghttp2|' ${WRKSRC}/*/Makefile.in
@${REINPLACE_CMD} -e '1d' ${WRKSRC}/script/fetch-ocsp-response
# lib/libnghttp2.* are not available until configure phase