aboutsummaryrefslogtreecommitdiff
path: root/www/nghttp2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-01 17:52:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-01 17:52:18 +0000
commit4171a3205ff91389282f230244cda2c3cdff1c39 (patch)
tree0aefd4f24a8c1de94cacdb2ce3ec76e83f5edb82 /www/nghttp2
parent7696213a1f5221ff8bc746f320f1d63ea0ca4983 (diff)
downloadports-4171a3205ff91389282f230244cda2c3cdff1c39.tar.gz
ports-4171a3205ff91389282f230244cda2c3cdff1c39.zip
- Cosmetic change
- Remove unnecessary second argument of @sample
Notes
Notes: svn path=/head/; revision=425067
Diffstat (limited to 'www/nghttp2')
-rw-r--r--www/nghttp2/Makefile24
-rw-r--r--www/nghttp2/pkg-plist2
2 files changed, 11 insertions, 15 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 05f1b8b0b83b..3986d06d3863 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -12,13 +12,12 @@ COMMENT= HTTP/2.0 C Library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= APP SPDY ASIO DOCS HPACK
+OPTIONS_DEFINE= APP ASIO DOCS HPACK SPDY
OPTIONS_DEFAULT=APP HPACK SPDY
OPTIONS_SUB= yes
-
-USE_RC_SUBR= nghttpx
-
-USE_GITHUB= yes
+APP_DESC= Build h2load, nghttp, nghttpd and nghttpx
+SPDY_DESC= Enable SPDY in h2load and nghttpx
+SPDY_IMPLIES= APP
CONFIGURE_ARGS= --disable-python-bindings \
--disable-examples
@@ -30,32 +29,29 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_CXXSTD= c++11
USE_LDCONFIG= yes
+USE_RC_SUBR= nghttpx
USES= autoreconf compiler:c++11-lib gmake libtool localbase pathfix pkgconfig ssl
PORTDATA= fetch-ocsp-response
PORTDOCS= *
-APP_DESC= Build nghttp, nghttpd, nghttpx, h2load
+USE_GITHUB= yes
+
APP_BUILD_DEPENDS= libev>=4.15:devel/libev
-APP_LIB_DEPENDS= libev.so:devel/libev
+APP_CONFIGURE_OFF= --without-libxml2
APP_CONFIGURE_ENABLE= app
+APP_LIB_DEPENDS= libev.so:devel/libev
APP_USE= GNOME=libxml2
-APP_CONFIGURE_OFF= --without-libxml2
-
ASIO_BUILD_DEPENDS= boost-libs>=1.54.0:devel/boost-libs
ASIO_CONFIGURE_OFF= --with-boost=no
ASIO_CONFIGURE_ON= --enable-asio-lib --with-boost-asio --with-boost-system --with-boost-thread
ASIO_LIB_DEPENDS= libboost_thread.so:devel/boost-libs
ASIO_RUN_DEPENDS= boost-libs>=1.54.0:devel/boost-libs
-
HPACK_CONFIGURE_ENABLE= hpack-tools
HPACK_LIB_DEPENDS= libjansson.so:devel/jansson
-
-SPDY_DESC= Enable SPDY in nghttpx and h2load
SPDY_BUILD_DEPENDS= spdylay>=1.3.0:www/spdylay
-SPDY_LIB_DEPENDS= libspdylay.so:www/spdylay
-SPDY_IMPLIES= APP
SPDY_CONFIGURE_WITH= spdylay
+SPDY_LIB_DEPENDS= libspdylay.so:www/spdylay
.include <bsd.port.pre.mk>
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
index be6b7a4b3a5d..0d1e0ab1b563 100644
--- a/www/nghttp2/pkg-plist
+++ b/www/nghttp2/pkg-plist
@@ -4,7 +4,7 @@
%%APP%%bin/nghttp
%%APP%%bin/nghttpd
%%APP%%bin/nghttpx
-@sample etc/nghttpx/nghttpx.conf.sample etc/nghttpx/nghttpx.conf
+@sample etc/nghttpx/nghttpx.conf.sample
%%ASIO%%include/nghttp2/asio_http2.h
%%ASIO%%include/nghttp2/asio_http2_client.h
%%ASIO%%include/nghttp2/asio_http2_server.h