aboutsummaryrefslogtreecommitdiff
path: root/www/nghttp2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-20 23:53:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-20 23:53:22 +0000
commitc9d85540b6fe4b3614b46c7fde05d8912f27d360 (patch)
treeba58a1bcdaadbce4dca30f285ce8e61dbcf92edb /www/nghttp2
parent430a5372f2e4f0a9979bb81f9efb2cfb3faf4d35 (diff)
downloadports-c9d85540b6fe4b3614b46c7fde05d8912f27d360.tar.gz
ports-c9d85540b6fe4b3614b46c7fde05d8912f27d360.zip
- Fix build for hosts without __cxa_thread_atexit
Notes
Notes: svn path=/head/; revision=426639
Diffstat (limited to 'www/nghttp2')
-rw-r--r--www/nghttp2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index b5ab1175d70f..478345a4f399 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -59,6 +59,13 @@ SPDY_LIB_DEPENDS= libspdylay.so:www/spdylay
CPPFLAGS+= -D_GLIBCXX_USE_C99
.endif
+# Disable thread_local support for hosts without __cxa_thread_atexit()
+# See PR/192320 for details
+.if (${OSVERSION} < 1003506) || ((${OSVERSION} >= 1100000) && (${OSVERSION} < 1100122)) || (${OSVERSION} == 1100500)
+post-configure:
+ @${REINPLACE_CMD} -e '/HAVE_THREAD_LOCAL/d' ${WRKSRC}/config.h
+.endif
+
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
CONFIGURE_ARGS+=--with-jemalloc
.endif