aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile.extmod
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-10-30 18:08:16 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 13:50:53 +0000
commit45526ecbeec33dbb87f0b678d4c04988aab9b657 (patch)
treeb77614b463af0ed929512fcc838ff5cb20c96275 /www/nginx-devel/Makefile.extmod
parenta148ebec4e0afe980f949de0dea5ef4931cb7e86 (diff)
downloadports-45526ecbeec33dbb87f0b678d4c04988aab9b657.tar.gz
ports-45526ecbeec33dbb87f0b678d4c04988aab9b657.zip
framework: Add new USES 'magick' for graphics/ImageMagick*
A new USES has been added to depend on ImageMagick. USES=magick adds a LIB_DEPENDS on graphics/ImageMagick${IMAGEMAGICK_DEFAULT}. If a specific version is required, use for example USES=magick:6 resp. USES=magick:7 If only a build, run or test is required, use for example USES=magick:build resp. USES=magick:6,build,test If a dependency on the nox11 flavor is required, use for example USES=magick:nox11 resp. USES=magick:7,nox11,run,test See magick.mk for more details on the available flags. The tree has been completely converted to make use of this. Approved by: bapt Differential Revision: https://reviews.freebsd.org/D32754
Diffstat (limited to 'www/nginx-devel/Makefile.extmod')
-rw-r--r--www/nginx-devel/Makefile.extmod4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/nginx-devel/Makefile.extmod b/www/nginx-devel/Makefile.extmod
index 368297fc8371..95995623743c 100644
--- a/www/nginx-devel/Makefile.extmod
+++ b/www/nginx-devel/Makefile.extmod
@@ -299,8 +299,8 @@ SHIBBOLETH_VARS= DSO_EXTMODS+=shibboleth
SLOWFS_CACHE_GH_TUPLE= baysao:ngx_slowfs_cache:d011a18:slowfs_cache
SLOWFS_CACHE_VARS= DSO_EXTMODS+=slowfs_cache
-SMALL_LIGHT_LIB_DEPENDS= libMagickWand-6.so:graphics/ImageMagick6 \
- libpcre.so:devel/pcre
+SMALL_LIGHT_USES= magick:6
+SMALL_LIGHT_LIB_DEPENDS= libpcre.so:devel/pcre
SMALL_LIGHT_GH_TUPLE= kawakibi:ngx_small_light:2f5e1d0:small_light
SMALL_LIGHT_VARS= DSO_EXTMODS+=small_light