aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2011-04-12 10:20:31 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2011-04-12 10:20:31 +0000
commit94fe64e9c3b0a40071acb50d0b3639ccf8526efb (patch)
tree4966066a980579cf5a975646dde11efd8c54c810 /www/nginx-devel/Makefile
parent48c298fafc18c8e78dbccafb55d64a2f841ba8eb (diff)
downloadports-94fe64e9c3b0a40071acb50d0b3639ccf8526efb.tar.gz
ports-94fe64e9c3b0a40071acb50d0b3639ccf8526efb.zip
Update to latest stable version 1.0.0.
For speed-up rails applications don't build debugging information for passenger module by default. Otherwise WITH_DEBUG required. Remove needless nginx.8 for www/nginx, now its in the distro. <ChangeLog> *) Bugfix: a cache manager might hog CPU after reload. Thanks to Maxim Dounin. *) Bugfix: an "image_filter crop" directive worked incorrectly coupled with an "image_filter rotate 180" directive. *) Bugfix: a "satisfy any" directive disabled custom 401 error page. </ChangeLog>
Notes
Notes: svn path=/head/; revision=272600
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 1ff6f599c345..7dc11f3c363b 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.9.7
+PORTVERSION= 1.0.0
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -410,6 +410,10 @@ MASTER_SITES+= RF/passenger/:passenger
DISTFILES+= passenger-${PASSENGER_VERSION}.tar.gz:passenger
CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-passenger::build::nginx.rb
+.if !defined(WITH_DEBUG)
+CONFIGURE_ENV+= OPTIMIZE="yes"
+CFLAGS+= -DNDEBUG
+.endif
.endif
.if defined(WITH_SLOWFS_CACHE_MODULE)