aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2012-08-21 03:38:25 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2012-08-21 03:38:25 +0000
commitc3e5589cf2e55cf018533d53cbd3b670937af633 (patch)
tree5c52bc0a63dd452fc2fcc93c5c391aeaec7579f8 /www/nginx-devel/Makefile
parent47b6acb9e500226465b3dba8752d35a0a36d5b7b (diff)
downloadports-c3e5589cf2e55cf018533d53cbd3b670937af633.tar.gz
ports-c3e5589cf2e55cf018533d53cbd3b670937af633.zip
Update third-party http_substitutions_filter module from 0.5.2.r59 to 0.6.0,
relocated to github. Fix typo for upstream_fair module. [*] Submitted by: Artis Caune <Artis.Caune@gmail.com> [*] PR: 170795 [*]
Notes
Notes: svn path=/head/; revision=302838
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index e4837013550c..0c800308f948 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -457,12 +457,11 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_VERSIO
.endif
.if ${PORT_OPTIONS:MHTTP_SUBS_FILTER}
-USE_HTTP_REWRITE= yes
-NGINX_HTTP_SUBS_FILTER_VERSION= 0.5.2.r59
-MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
-MASTER_SITE_SUBDIR+= osa/:subs_filter
-DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}.tar.gz:subs_filter
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_VERSION}
+GIT_HTTP_SUBS_FILTER_VERSION= 0-gb32237d
+FETCH_ARGS= -pRr
+MASTER_SITES+= https://github.com/yaoweibin/ngx_http_substitutions_filter_module/tarball/master/:subs_filter
+DISTFILES+= yaoweibin-ngx_http_substitutions_filter_module-${GIT_HTTP_SUBS_FILTER_VERSION}.tar.gz:subs_filter
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/yaoweibin-ngx_http_substitutions_filter_module-${GIT_HTTP_SUBS_FILTER_VERSION:S/^0-g//}
.endif
.if ${PORT_OPTIONS:MHTTP_SECURE_LINK}
@@ -854,7 +853,7 @@ USE_OPENSSL= yes
pre-everything::
@${ECHO_MSG}
-.if ${PORT_OPTIONS:MHTTP_UPSTREAM_FAIR)
+.if ${PORT_OPTIONS:MHTTP_UPSTREAM_FAIR}
@${ECHO_MSG} "Enable http_ssl module to build upstream_fair with SSL support"
.endif
.if ${PORT_OPTIONS:MPASSENGER}