aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/files
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2019-11-15 15:38:08 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2019-11-15 15:38:08 +0000
commit03fb8de76ca749280b0d8f9796357ab1b1c9eb51 (patch)
tree4268fe0b0ba214b1ec0ec2ffe1a8559f095fa150 /www/nginx-devel/files
parent2f780c9a233b445f434c708865ca2120a2a0197d (diff)
downloadports-03fb8de76ca749280b0d8f9796357ab1b1c9eb51.tar.gz
ports-03fb8de76ca749280b0d8f9796357ab1b1c9eb51.zip
Merge the r517639 for third-party passenger module from the
www/nginx to fix the build. (*) While I'm here sort pkg-plist. Bump PORTREVISION. PR: 241753 (*)
Notes
Notes: svn path=/head/; revision=517683
Diffstat (limited to 'www/nginx-devel/files')
-rw-r--r--www/nginx-devel/files/extra-patch-passenger-system-calls52
1 files changed, 52 insertions, 0 deletions
diff --git a/www/nginx-devel/files/extra-patch-passenger-system-calls b/www/nginx-devel/files/extra-patch-passenger-system-calls
new file mode 100644
index 000000000000..6ce971b856c0
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-passenger-system-calls
@@ -0,0 +1,52 @@
+--- ../passenger-6.0.4/src/cxx_supportlib/oxt/system_calls.cpp.original 2019-11-15 01:35:57.674449000 +0200
++++ ../passenger-6.0.4/src/cxx_supportlib/oxt/system_calls.cpp 2019-11-15 01:36:06.053234000 +0200
+@@ -132,15 +132,15 @@
+ _my_errno = errno; \
+ } while ((error_expression) \
+ && _my_errno == EINTR \
+- && (!this_thread::syscalls_interruptable() \
+- || !(_intr_requested = this_thread::interruption_requested())) \
++ && (!boost::this_thread::syscalls_interruptable() \
++ || !(_intr_requested = boost::this_thread::interruption_requested())) \
+ ); \
+ if (OXT_LIKELY(ctx != NULL)) { \
+ ctx->syscall_interruption_lock.lock(); \
+ } \
+ if ((error_expression) \
+ && _my_errno == EINTR \
+- && this_thread::syscalls_interruptable() \
++ && boost::this_thread::syscalls_interruptable() \
+ && _intr_requested) { \
+ throw thread_interrupted(); \
+ } \
+@@ -284,8 +284,8 @@
+ }
+ if (ret == -1
+ && errno == EINTR
+- && this_thread::syscalls_interruptable()
+- && this_thread::interruption_requested()) {
++ && boost::this_thread::syscalls_interruptable()
++ && boost::this_thread::interruption_requested()) {
+ throw thread_interrupted();
+ } else {
+ return ret;
+@@ -662,8 +662,8 @@
+ }
+ } while (ret == -1
+ && e == EINTR
+- && (!this_thread::syscalls_interruptable()
+- || !(intr_requested = this_thread::interruption_requested()))
++ && (!boost::this_thread::syscalls_interruptable()
++ || !(intr_requested = boost::this_thread::interruption_requested()))
+ );
+
+ if (OXT_UNLIKELY(ctx != NULL)) {
+@@ -672,7 +672,7 @@
+
+ if (ret == -1
+ && e == EINTR
+- && this_thread::syscalls_interruptable()
++ && boost::this_thread::syscalls_interruptable()
+ && intr_requested) {
+ throw thread_interrupted();
+ }