aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2020-09-30 16:12:16 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2020-09-30 16:12:16 +0000
commit0cfd7ac66a26a0d56e0b3fffc669a69545f07cd7 (patch)
treef29d8d9a709ddf598d764554b7151c31b851002c /www/nginx-devel
parentda83ad980bae5c3463174a0af774669c6572b4ba (diff)
downloadports-0cfd7ac66a26a0d56e0b3fffc669a69545f07cd7.tar.gz
ports-0cfd7ac66a26a0d56e0b3fffc669a69545f07cd7.zip
Fix build with -fno-common.
Bump PORTREVISION. Submitted by: vanilla
Notes
Notes: svn path=/head/; revision=550720
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx-devel/Makefile.extmod2
-rw-r--r--www/nginx-devel/files/extra-patch-nchan-store-private.h10
-rw-r--r--www/nginx-devel/files/extra-patch-nchan-store-redis-redis_lua_commands.h12
4 files changed, 14 insertions, 12 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 816199f4cc19..26e17d132064 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= nginx
PORTVERSION= 1.19.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
diff --git a/www/nginx-devel/Makefile.extmod b/www/nginx-devel/Makefile.extmod
index 623d2ecf06be..ea70ccb1ed31 100644
--- a/www/nginx-devel/Makefile.extmod
+++ b/www/nginx-devel/Makefile.extmod
@@ -138,7 +138,7 @@ HTTP_NOTICE_VARS= DSO_EXTMODS+=notice
HTTP_PUSH_GH_TUPLE= slact:nchan:v1.2.7:push
HTTP_PUSH_VARS= DSO_EXTMODS+=push
-HTTP_PUSH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-nchan-store-private.h
+HTTP_PUSH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-nchan-store-redis-redis_lua_commands.h
HTTP_PUSH_STREAM_GH_TUPLE= wandenberg:nginx-push-stream-module:0.5.4:pushstream
HTTP_PUSH_STREAM_VARS= DSO_EXTMODS+=pushstream
diff --git a/www/nginx-devel/files/extra-patch-nchan-store-private.h b/www/nginx-devel/files/extra-patch-nchan-store-private.h
deleted file mode 100644
index 72d3f5e75afd..000000000000
--- a/www/nginx-devel/files/extra-patch-nchan-store-private.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../nchan-1.2.7/src/store/memory/store-private.h.orig 2020-09-20 13:11:33.781569000 +0200
-+++ ../nchan-1.2.7/src/store/memory/store-private.h 2020-09-20 13:11:48.679855000 +0200
-@@ -172,6 +172,6 @@
- void memstore_chanhead_release(memstore_channel_head_t *ch, char *label);
- void memstore_chanhead_reserve(memstore_channel_head_t *ch, const char *label);
-
--uint16_t memstore_worker_generation; //times nginx has been restarted + 1
-+extern uint16_t memstore_worker_generation; //times nginx has been restarted + 1
-
- #endif /*MEMSTORE_PRIVATE_HEADER*/
diff --git a/www/nginx-devel/files/extra-patch-nchan-store-redis-redis_lua_commands.h b/www/nginx-devel/files/extra-patch-nchan-store-redis-redis_lua_commands.h
new file mode 100644
index 000000000000..9923e5984822
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-nchan-store-redis-redis_lua_commands.h
@@ -0,0 +1,12 @@
+--- ../nchan-1.2.7/src/store/redis/redis_lua_commands.h.orig 2020-09-30 23:51:52.116513000 +0800
++++ ../nchan-1.2.7/src/store/redis/redis_lua_commands.h 2020-09-30 23:52:11.164617000 +0800
+@@ -63,7 +63,7 @@ typedef struct {
+ redis_lua_script_t subscriber_unregister;
+
+ } redis_lua_scripts_t;
+-redis_lua_scripts_t redis_lua_scripts;
+-const int redis_lua_scripts_count;
++extern redis_lua_scripts_t redis_lua_scripts;
++extern const int redis_lua_scripts_count;
+ #define REDIS_LUA_SCRIPTS_EACH(script) \
+ for((script)=(redis_lua_script_t *)&redis_lua_scripts; (script) < (redis_lua_script_t *)(&redis_lua_scripts + 1); (script)++)