aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2014-01-04 05:01:53 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2014-01-04 05:01:53 +0000
commit2461524372523c7a52d6df78303ae3d9a88c6293 (patch)
treed44ef74ba4710c711ecdb64fff7b2d489d76bc3d /www/nginx-devel
parent5f229d6092245fd600254d7b6835b497d9391c7e (diff)
downloadports-2461524372523c7a52d6df78303ae3d9a88c6293.tar.gz
ports-2461524372523c7a52d6df78303ae3d9a88c6293.zip
Update from 4.0.30 to 4.0.33:
o) www/rubygem-passenger; o) third-party modules for www/nginx and www/nginx-devel. <ChangeLog> Release 4.0.33 -------------- * Fixed a compatibility problem in passenger-install-apache2-module with Ruby 1.8. The language selection menu didn't work properly. Release 4.0.32 -------------- * Fixed compatibility problems with old Ruby versions that didn't include RubyGems. Release 4.0.31 -------------- * Introduced a new tool: `passenger-config restart-app`. With this command you can initiate an application restart without touching restart.txt. Unlike touching restart.txt, this tool initiates the restart immediately instead of on the next request. * Fixed some problems in process spawning and request handling. * Fixed some problems with the handling of HTTP chunked transfer encoding bodies. These problems only occurred in Ruby. * Fixed the HelperAgent, upon shutdown, not correctly waiting 5 seconds until all clients have disconnected. Fixes issue #884. * Fixed compilation problems on FreeBSD. * Fixed some C++ strict aliasing problems. * Fixed some problems with spawning applications that print messages without newline during startup. Fixes issue #1039. * Fixed potential hangs on JRuby when Ctrl-C is used to shutdown the server. Fixes issue #1035. * When Phusion Passenger is installed through the Debian package, passenger-install-apache2-module now checks whether the Apache module package (libapache2-mod-passenger) is properly installed, and installs it using apt-get if it's not installed. Fixes issue #1031. * The `passenger-status --show=xml` command no longer prints the non-XML preamble, such as the version number and the time. Fixes issue #1037. * The Ruby native extension check whether it's loaded against the right Ruby version, to prevent problems when people upgrade Ruby without recompiling their native extensions. * Various other minor Debian packaging improvements. </ChangeLog>
Notes
Notes: svn path=/head/; revision=338622
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx-devel/distinfo4
-rw-r--r--www/nginx-devel/files/extra-patch-passenger-build-nginx.rb4
3 files changed, 5 insertions, 5 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index baa639901201..e75c8e8473be 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -644,7 +644,7 @@ CONFIGURE_ARGS+=--without-http_rewrite_module \
.endif
.if ${PORT_OPTIONS:MPASSENGER}
-PASSENGER_VERSION= 4.0.30
+PASSENGER_VERSION= 4.0.33
MASTER_SITES+= http://s3.amazonaws.com/phusion-passenger/releases/:passenger
DISTFILES+= passenger-${PASSENGER_VERSION}.tar.gz:passenger
CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 9b37873f1a49..ff42360770e2 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -72,8 +72,8 @@ SHA256 (modsecurity-apache_2.7.5.tar.gz) = 9e907536278d8da80d3dbb29aeffe9c4ec37c
SIZE (modsecurity-apache_2.7.5.tar.gz) = 1045387
SHA256 (naxsi-core-0.50.tgz) = 7cece5f9d9c5df9e09af1e1023bc8e04bbbbe953e67461b893b8240e82ca52ef
SIZE (naxsi-core-0.50.tgz) = 49809
-SHA256 (passenger-4.0.30.tar.gz) = 295849fabfa8abe2c7227effea2e81ccf9925ff27310372ce02cd00d28401307
-SIZE (passenger-4.0.30.tar.gz) = 4304256
+SHA256 (passenger-4.0.33.tar.gz) = 31d0e96e2c025a086a5c6ebdb06f7539a2756d74b0703e2f88de7c5425f41a8d
+SIZE (passenger-4.0.33.tar.gz) = 4229510
SHA256 (ngx_postgres-0.9.tar.gz) = aac0141e73b5c440927b7e040072f120b36e49deb2ff36ad00ff96a80622fbec
SIZE (ngx_postgres-0.9.tar.gz) = 41022
SHA256 (agentzh-rds-csv-nginx-module-v0.05-0-g607e26b.tar.gz) = 3fa9cb3960a97f505c9ad0cc8683c8fe17ba98aa98d003e255bf214e5144751c
diff --git a/www/nginx-devel/files/extra-patch-passenger-build-nginx.rb b/www/nginx-devel/files/extra-patch-passenger-build-nginx.rb
index 89bc33d3161c..c87bfec43799 100644
--- a/www/nginx-devel/files/extra-patch-passenger-build-nginx.rb
+++ b/www/nginx-devel/files/extra-patch-passenger-build-nginx.rb
@@ -1,5 +1,5 @@
---- ../passenger-4.0.30/build/nginx.rb.orig 2013-10-12 11:05:08.000000000 +0400
-+++ ../passenger-4.0.30/build/nginx.rb 2013-10-12 11:06:18.000000000 +0400
+--- ../passenger-4.0.33/build/nginx.rb.orig 2013-10-12 11:05:08.000000000 +0400
++++ ../passenger-4.0.33/build/nginx.rb 2013-10-12 11:06:18.000000000 +0400
@@ -32,16 +32,12 @@
desc "Build Nginx support files"
task :nginx => [