aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2013-01-12 07:26:28 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2013-01-12 07:26:28 +0000
commit93f4b1dc3b00cd521e37ea13c9691432cd3fef70 (patch)
tree1fd773e0ab5f3358cee30cd3e224f23dc939fcc5 /www/nginx-devel
parent0bf7e09b4667ba62077201f592edf37f7d8b94ed (diff)
downloadports-93f4b1dc3b00cd521e37ea13c9691432cd3fef70.tar.gz
ports-93f4b1dc3b00cd521e37ea13c9691432cd3fef70.zip
Update from 1.3.8 to 1.3.11.
Update SPDY patch from version 53 to 54. Chunked support has been implemented and enabled by default in nginx' base, so remove support for third-party chunkin module. There are two third-party features are temporary disabled: o) ngx_http_upload_module; o) syslog support. <ChangeLog> Changes with nginx 1.3.11 10 Jan 2013 *) Bugfix: a segmentation fault might occur if logging was used; the bug had appeared in 1.3.10. *) Bugfix: the "proxy_pass" directive did not work with IP addresses without port specified; the bug had appeared in 1.3.10. *) Bugfix: a segmentation fault occurred on start or during reconfiguration if the "keepalive" directive was specified more than once in a single upstream block. *) Bugfix: parameter "default" of the "geo" directive did not set default value for IPv6 addresses. Changes with nginx 1.3.10 25 Dec 2012 *) Change: domain names specified in configuration file are now resolved to IPv6 addresses as well as IPv4 ones. *) Change: now if the "include" directive with mask is used on Unix systems, included files are sorted in alphabetical order. *) Change: the "add_header" directive adds headers to 201 responses. *) Feature: the "geo" directive now supports IPv6 addresses in CIDR notation. *) Feature: the "flush" and "gzip" parameters of the "access_log" directive. *) Feature: variables support in the "auth_basic" directive. *) Bugfix: nginx could not be built with the ngx_http_perl_module in some cases. *) Bugfix: a segmentation fault might occur in a worker process if the ngx_http_xslt_module was used. *) Bugfix: nginx could not be built on MacOSX in some cases. Thanks to Piotr Sikora. *) Bugfix: the "limit_rate" directive with high rates might result in truncated responses on 32-bit platforms. Thanks to Alexey Antropov. *) Bugfix: a segmentation fault might occur in a worker process if the "if" directive was used. Thanks to Piotr Sikora. *) Bugfix: a "100 Continue" response was issued with "413 Request Entity Too Large" responses. *) Bugfix: the "image_filter", "image_filter_jpeg_quality" and "image_filter_sharpen" directives might be inherited incorrectly. Thanks to Ian Babrou. *) Bugfix: "crypt_r() failed" errors might appear if the "auth_basic" directive was used on Linux. *) Bugfix: in backup servers handling. Thanks to Thomas Chen. *) Bugfix: proxied HEAD requests might return incorrect response if the "gzip" directive was used. Changes with nginx 1.3.9 27 Nov 2012 *) Feature: support for chunked transfer encoding while reading client request body. *) Feature: the $request_time and $msec variables can now be used not only in the "log_format" directive. *) Bugfix: cache manager and cache loader processes might not be able to start if more than 512 listen sockets were used. *) Bugfix: in the ngx_http_dav_module. </ChangeLog>
Notes
Notes: svn path=/head/; revision=310263
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile18
-rw-r--r--www/nginx-devel/distinfo10
2 files changed, 8 insertions, 20 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 97765748d194..3644ca8e7a9b 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nginx
-PORTVERSION= 1.3.8
-PORTREVISION= 1
+PORTVERSION= 1.3.11
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -74,7 +73,6 @@ OPTIONS_DEFINE= \
HTTP_UPSTREAM_STICKY \
HTTP_ZIP \
ARRAYVAR \
- CHUNKIN \
DRIZZLE \
ENCRYPTSESSION \
FORMINPUT \
@@ -162,7 +160,6 @@ HTTP_UPSTREAM_HASH_DESC= 3rd party upstream hash module
HTTP_UPSTREAM_STICKY_DESC= 3rd party upstream sticky module
HTTP_ZIP_DESC= 3rd party http_zip module
ARRAYVAR_DESC= 3rd party array_var module
-CHUNKIN_DESC= 3rd party chunkin module
DRIZZLE_DESC= 3rd party drizzlie module
ENCRYPTSESSION_DESC= 3rd party encrypted_session module
FORMINPUT_DESC= 3rd party form_input module
@@ -493,6 +490,7 @@ CONFIGURE_ARGS+=--with-http_sub_module
.endif
.if ${PORT_OPTIONS:MHTTP_UPLOAD}
+IGNORE= incompatible with nginx_upload_module-2.2.0
NGINX_UPLOAD_VERSION= 2.2.0
MASTER_SITES+= http://www.grid.net.ru/nginx/download/:upload
DISTFILES+= nginx_upload_module-${NGINX_UPLOAD_VERSION}.tar.gz:upload
@@ -544,15 +542,6 @@ DISTFILES+= mod_zip-${NGINX_ZIP_VERSION}.tar.gz:zip
CONFIGURE_ARGS+=--add-module=${WRKDIR}/mod_zip-${NGINX_ZIP_VERSION}
.endif
-.if ${PORT_OPTIONS:MCHUNKIN}
-NGINX_CHUNKIN_VERSION= 0.22rc1
-GIT_CHUNKIN_VERSION= 0-gb0a3ee3
-FETCH_ARGS= -pRr
-MASTER_SITES+= https://github.com/agentzh/chunkin-nginx-module/tarball/v${NGINX_CHUNKIN_VERSION}/:chunkin
-DISTFILES+= agentzh-chunkin-nginx-module-v${NGINX_CHUNKIN_VERSION}-${GIT_CHUNKIN_VERSION}.tar.gz:chunkin
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-chunkin-nginx-module-${GIT_CHUNKIN_VERSION:S/^0-g//}
-.endif
-
.if ${PORT_OPTIONS:MDRIZZLE}
LIB_DEPENDS+= drizzle:${PORTSDIR}/databases/drizzle
NGINX_DRIZZLE_VERSION= 0.1.4
@@ -736,6 +725,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_VERSI
.endif
.if ${PORT_OPTIONS:MSYSLOG_SUPPORT}
+IGNORE= incompatible with syslog_support patch
NGINX_SYSLOG_SUPPORT_FACILITY?= LOG_DAEMON
CONFIGURE_ARGS+=--with-syslog --with-syslog-facility=${NGINX_SYSLOG_SUPPORT_FACILITY}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-syslog_support
@@ -778,7 +768,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-xss-nginx-module-${GIT_XSS_VERSIO
.if ${PORT_OPTIONS:MSPDY}
USE_OPENSSL_PORT= yes
USE_HTTP_SSL= yes
-NGINX_SPDY_VERSION= 53
+NGINX_SPDY_VERSION= 54
PATCH_SITES= http://nginx.org/patches/spdy/:spdy
PATCHFILES= patch.spdy-${NGINX_SPDY_VERSION}.txt:spdy
.endif
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 0861f5eb4700..b7de65e31c95 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-1.3.8.tar.gz) = 8d68f9224f4616c987208bcb3a0bf1ae03740c5ec313b220f995ba50d826fe1c
-SIZE (nginx-1.3.8.tar.gz) = 738216
+SHA256 (nginx-1.3.11.tar.gz) = a3e0921e0021e7049dd0fd60206aa1725c24019ffc64eba162df3e35712ce07e
+SIZE (nginx-1.3.11.tar.gz) = 744064
SHA256 (giom-nginx_accept_language_module-02262ce.tar.gz) = 3191f4caa70d9a8942c4f10b6abaaa96af451991d4b5e1e3d7b991376b00bf0c
SIZE (giom-nginx_accept_language_module-02262ce.tar.gz) = 3398
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
@@ -52,8 +52,6 @@ SHA256 (nginx-sticky-module-1.0.tar.gz) = 415beaac0dd229c271128b461f6059601f4889
SIZE (nginx-sticky-module-1.0.tar.gz) = 114184
SHA256 (mod_zip-1.1.6.tar.gz) = d30546b4be8308c721df0240ebc38c474c6b577381a110321eded6dbed5104b1
SIZE (mod_zip-1.1.6.tar.gz) = 21991
-SHA256 (agentzh-chunkin-nginx-module-v0.22rc1-0-gb0a3ee3.tar.gz) = 23c41a6743803f8521c55b9c76d5c35b20e9870576478ce9152d2ecddffbf2ca
-SIZE (agentzh-chunkin-nginx-module-v0.22rc1-0-gb0a3ee3.tar.gz) = 32575
SHA256 (chaoslawful-drizzle-nginx-module-v0.1.4-0-g59e12ad.tar.gz) = c9b476acce35bdf904b2276cf6a365f68d66994824d5df874615629a46809d1a
SIZE (chaoslawful-drizzle-nginx-module-v0.1.4-0-g59e12ad.tar.gz) = 61064
SHA256 (agentzh-encrypted-session-nginx-module-v0.02-0-gc752861.tar.gz) = 9689fbef49b6c3b4c4fc67b21fe1aa60880a374af988e93b36b8cf5335109cd9
@@ -108,5 +106,5 @@ SHA256 (calio-form-input-nginx-module-v0.07rc5-0-gd41681d.tar.gz) = 831bb3fa3392
SIZE (calio-form-input-nginx-module-v0.07rc5-0-gd41681d.tar.gz) = 11048
SHA256 (calio-iconv-nginx-module-v0.10rc7-0-gabdac17.tar.gz) = bc35d461efccb29b7affda5a397d86d89f5c860fcd9d300ac2d6d7f7667c22b1
SIZE (calio-iconv-nginx-module-v0.10rc7-0-gabdac17.tar.gz) = 12060
-SHA256 (patch.spdy-53.txt) = 895efa2477330fe2d732568f0123574de84da4bff92aba41d41461b9ca9d38c8
-SIZE (patch.spdy-53.txt) = 148166
+SHA256 (patch.spdy-54.txt) = 0b2f1933a07cc720ef5e6621c09e6253f601d32ac10184bca4f2dca176c9e904
+SIZE (patch.spdy-54.txt) = 148212