aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2021-10-19 14:39:24 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2021-10-19 14:42:01 +0000
commitadc7097c90ee5e8db0d063200faa689034ac91f0 (patch)
treedafb1d1481ea1939bf535e5122c29fc15f32b645 /www/nginx-devel
parentfb3f11e5db16d91932828a877a2238f0e482ece3 (diff)
downloadports-adc7097c90ee5e8db0d063200faa689034ac91f0.tar.gz
ports-adc7097c90ee5e8db0d063200faa689034ac91f0.zip
www/nginx-devel: update third-party SPNEGO module to it recent commit
Notify that one of the implementation of Kerberos5 needs to be chosen. Bump PORTREVISION.
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile8
-rw-r--r--www/nginx-devel/Makefile.extmod2
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-spnego-http-auth-nginx-module-config4
4 files changed, 13 insertions, 7 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 793d506eaa76..c2afddb17b1e 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME?= nginx
PORTVERSION= 1.21.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
@@ -222,6 +222,12 @@ CONFIGURE_ENV+= OPTIMIZE="yes"
CFLAGS+= -DNDEBUG
.endif
+.if ${PORT_OPTIONS:MHTTP_AUTH_KRB5} && (empty(PORT_OPTIONS:MGSSAPI_HEIMDAL) && empty(PORT_OPTIONS:MGSSAPI_MIT))
+IGNORE= required at least GSSAPI_HEIMDAL or \
+ GSSAPI_MIT_USES to be defined. Please do \
+ 'make config' again
+.endif
+
pre-everything::
@${ECHO_MSG}
.if ${PORT_OPTIONS:MHTTP_UPSTREAM_FAIR}
diff --git a/www/nginx-devel/Makefile.extmod b/www/nginx-devel/Makefile.extmod
index 83f84a00edd7..0e7f7a7e7d14 100644
--- a/www/nginx-devel/Makefile.extmod
+++ b/www/nginx-devel/Makefile.extmod
@@ -90,7 +90,7 @@ HTTP_ACCEPT_LANGUAGE_VARS= DSO_EXTMODS+=accept_language
HTTP_AUTH_DIGEST_GH_TUPLE= atomx:nginx-http-auth-digest:274490c:auth_digest
HTTP_AUTH_DIGEST_VARS= DSO_EXTMODS+=auth_digest
-HTTP_AUTH_KRB5_GH_TUPLE= stnoonan:spnego-http-auth-nginx-module:72c8ee0:auth_krb5
+HTTP_AUTH_KRB5_GH_TUPLE= stnoonan:spnego-http-auth-nginx-module:a06f9ef:auth_krb5
HTTP_AUTH_KRB5_VARS= DSO_EXTMODS+=auth_krb5
HTTP_AUTH_KRB5_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-spnego-http-auth-nginx-module-config
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index bf28c409a71e..063a66e07f46 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1634648725
+TIMESTAMP = 1634653086
SHA256 (nginx-1.21.3.tar.gz) = 14774aae0d151da350417efc4afda5cce5035056e71894836797e1f6e2d1175a
SIZE (nginx-1.21.3.tar.gz) = 1066609
SHA256 (nginx_mogilefs_module-1.0.4.tar.gz) = 7ac230d30907f013dff8d435a118619ea6168aa3714dba62c6962d350c6295ae
@@ -51,8 +51,8 @@ SHA256 (dvershinin-nginx_accept_language_module-5683967_GH0.tar.gz) = a58feb576f
SIZE (dvershinin-nginx_accept_language_module-5683967_GH0.tar.gz) = 3425
SHA256 (atomx-nginx-http-auth-digest-274490c_GH0.tar.gz) = 0839c33c2f8d519f92daae274f62cf87eb68415d562c6500ee3e3721ce80557c
SIZE (atomx-nginx-http-auth-digest-274490c_GH0.tar.gz) = 17815
-SHA256 (stnoonan-spnego-http-auth-nginx-module-72c8ee0_GH0.tar.gz) = df6be6e67a4a4a37db584effdf2326a7eca29891724363bd34d03967cc8e5c68
-SIZE (stnoonan-spnego-http-auth-nginx-module-72c8ee0_GH0.tar.gz) = 18502
+SHA256 (stnoonan-spnego-http-auth-nginx-module-a06f9ef_GH0.tar.gz) = f7b1559e730d75fd0eee82a0aef67e3ab026cc816e0413fb94d51c8ad87df883
+SIZE (stnoonan-spnego-http-auth-nginx-module-a06f9ef_GH0.tar.gz) = 18504
SHA256 (kvspb-nginx-auth-ldap-83c059b_GH0.tar.gz) = e76e9e117ad51af578a68fa7a30c256178796bb271fa77f01c93281a92b09921
SIZE (kvspb-nginx-auth-ldap-83c059b_GH0.tar.gz) = 18547
SHA256 (sto-ngx_http_auth_pam_module-v1.5.1_GH0.tar.gz) = 77676842919134af88a7b4bfca4470223e3a00d287d17c0dbdc9a114a685b6e7
diff --git a/www/nginx-devel/files/extra-patch-spnego-http-auth-nginx-module-config b/www/nginx-devel/files/extra-patch-spnego-http-auth-nginx-module-config
index 9357faf2bc29..20861efb1f7c 100644
--- a/www/nginx-devel/files/extra-patch-spnego-http-auth-nginx-module-config
+++ b/www/nginx-devel/files/extra-patch-spnego-http-auth-nginx-module-config
@@ -1,5 +1,5 @@
---- ../spnego-http-auth-nginx-module-72c8ee0/config.orig 2020-08-27 07:59:28.423636000 -0400
-+++ ../spnego-http-auth-nginx-module-72c8ee0/config 2020-08-27 08:01:42.152121000 -0400
+--- ../spnego-http-auth-nginx-module-a06f9ef/config.orig 2020-08-27 07:59:28.423636000 -0400
++++ ../spnego-http-auth-nginx-module-a06f9ef/config 2020-08-27 08:01:42.152121000 -0400
@@ -1,8 +1,9 @@
ngx_addon_name=ngx_http_auth_spnego_module
-ngx_feature_libs="-lgssapi_krb5 -lkrb5 -lcom_err"