aboutsummaryrefslogtreecommitdiff
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2019-01-15 12:35:35 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2019-01-15 12:35:35 +0000
commit90e79f86a78eed0468f7dc8418645e44681f6aef (patch)
tree4f8278a03e7dbaa2115493ca5ff54a175ef1d6c5 /www/nginx/Makefile
parentc36af6134b1811f0f3ddbe683149281563c9f4b7 (diff)
downloadports-90e79f86a78eed0468f7dc8418645e44681f6aef.tar.gz
ports-90e79f86a78eed0468f7dc8418645e44681f6aef.zip
revert r490211
That deleted GeoIP. GeoIP is EOL 15.02.2019. It should not have been deleted from NGINX. Users had no chance to switch to GeoIP2. GeoIP will be deleted on 15.2.2019 again from NGINX Sponsored by: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=490368
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 41f527b268a1..6ba8325c9e06 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.14.2
-PORTREVISION?= 5
+PORTREVISION?= 6
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/ \
@@ -70,7 +70,7 @@ NO_OPTIONS_SORT= yes
OPTIONS_GROUP= MAILGRP HTTPGRP
# Modules that are part of the base nginx distribution
OPTIONS_GROUP_HTTPGRP= GOOGLE_PERFTOOLS HTTP HTTP_ADDITION HTTP_AUTH_REQ \
- HTTP_CACHE HTTP_DAV HTTP_FLV HTTP_GUNZIP_FILTER HTTP_GZIP_STATIC \
+ HTTP_CACHE HTTP_DAV HTTP_FLV HTTP_GEOIP HTTP_GUNZIP_FILTER HTTP_GZIP_STATIC \
HTTP_IMAGE_FILTER HTTP_MP4 HTTP_PERL HTTP_RANDOM_INDEX HTTP_REALIP \
HTTP_REWRITE HTTP_SECURE_LINK HTTP_SLICE HTTP_SSL HTTP_STATUS HTTP_SUB \
HTTP_XSLT HTTPV2 STREAM STREAM_SSL STREAM_SSL_PREREAD
@@ -148,6 +148,8 @@ HTTP_AUTH_REQ_CONFIGURE_ON= --with-http_auth_request_module
HTTP_CACHE_CONFIGURE_OFF= --without-http-cache
HTTP_DAV_CONFIGURE_ON= --with-http_dav_module
HTTP_FLV_CONFIGURE_ON= --with-http_flv_module
+HTTP_GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
+HTTP_GEOIP_VARS= DSO_BASEMODS+=http_geoip_module
HTTP_GZIP_STATIC_CONFIGURE_ON= --with-http_gzip_static_module
HTTP_GUNZIP_FILTER_CONFIGURE_ON=--with-http_gunzip_module
HTTP_IMAGE_FILTER_LIB_DEPENDS= libgd.so:graphics/gd