aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2022-02-10 16:48:43 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2022-02-10 16:53:14 +0000
commit7ab2abfa9d0a0c7efec47aafe89e2e1faf535be8 (patch)
treea99916ee98fc15ebddc312c77c27a4e6ec94d565 /www/nginx
parent9065a22a53c7624071013d7168731eef9d488f79 (diff)
downloadports-7ab2abfa9d0a0c7efec47aafe89e2e1faf535be8.tar.gz
ports-7ab2abfa9d0a0c7efec47aafe89e2e1faf535be8.zip
www/nginx: update third-party spnego-http-auth module
There was an error when loading the module in nginx.conf. This update also fixes this error: nginx: [emerg] dlopen() "/usr/local/libexec/nginx/ngx_http_auth_spnego_module.so" failed (/usr/local/libexec/nginx/ngx_http_auth_spnego_module.so: Undefined symbol "__gss_krb5_mechanism_oid_desc") in /usr/local/etc/nginx/nginx.conf:7 nginx: configuration file /usr/local/etc/nginx/nginx.conf test failed PR: 261810 Sponsored by: Netzkommune GmbH
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/Makefile.extmod2
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config6
4 files changed, 8 insertions, 8 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 046424cfa732..a6cd3399c6d5 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -2,7 +2,7 @@
PORTNAME= nginx
PORTVERSION= 1.20.2
-PORTREVISION?= 6
+PORTREVISION?= 7
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
diff --git a/www/nginx/Makefile.extmod b/www/nginx/Makefile.extmod
index 4b7edbe4e9a5..0af2d63e5f7a 100644
--- a/www/nginx/Makefile.extmod
+++ b/www/nginx/Makefile.extmod
@@ -76,7 +76,7 @@ HTTP_AUTH_JWT_GH_TUPLE= TeslaGov:ngx-http-auth-jwt-module:80d89d9:http_auth_jwt
HTTP_AUTH_JWT_VARS= DSO_EXTMODS+=http_auth_jwt
HTTP_AUTH_JWT_LIB_DEPENDS= libjwt.so:www/libjwt libjansson.so:devel/jansson
-HTTP_AUTH_KRB5_GH_TUPLE= stnoonan:spnego-http-auth-nginx-module:72c8ee0:auth_krb5
+HTTP_AUTH_KRB5_GH_TUPLE= stnoonan:spnego-http-auth-nginx-module:c626163:auth_krb5
HTTP_AUTH_KRB5_VARS= DSO_EXTMODS+=auth_krb5
HTTP_AUTH_KRB5_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-spnego-http-auth-nginx-module-config
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index be8e76a93692..f59d9270a69c 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1641727913
+TIMESTAMP = 1644495863
SHA256 (nginx-1.20.2.tar.gz) = 958876757782190a1653e14dc26dfc7ba263de310e04c113e11e97d1bef45a42
SIZE (nginx-1.20.2.tar.gz) = 1062124
SHA256 (nginx_mogilefs_module-1.0.4.tar.gz) = 7ac230d30907f013dff8d435a118619ea6168aa3714dba62c6962d350c6295ae
@@ -51,8 +51,8 @@ SHA256 (atomx-nginx-http-auth-digest-cd86418_GH0.tar.gz) = 9858b202e5009da4047ac
SIZE (atomx-nginx-http-auth-digest-cd86418_GH0.tar.gz) = 17869
SHA256 (TeslaGov-ngx-http-auth-jwt-module-80d89d9_GH0.tar.gz) = 1b71290a0eab6a0bb6ab75e1228a302cf76c82f3284ad0eb7e8b2bfa110582e7
SIZE (TeslaGov-ngx-http-auth-jwt-module-80d89d9_GH0.tar.gz) = 14674
-SHA256 (stnoonan-spnego-http-auth-nginx-module-72c8ee0_GH0.tar.gz) = df6be6e67a4a4a37db584effdf2326a7eca29891724363bd34d03967cc8e5c68
-SIZE (stnoonan-spnego-http-auth-nginx-module-72c8ee0_GH0.tar.gz) = 18502
+SHA256 (stnoonan-spnego-http-auth-nginx-module-c626163_GH0.tar.gz) = dac75d65453744ffe0f7af248f10f98fc89efca07303aa45a610805e57c588fc
+SIZE (stnoonan-spnego-http-auth-nginx-module-c626163_GH0.tar.gz) = 24404
SHA256 (kvspb-nginx-auth-ldap-42d195d_GH0.tar.gz) = 78d74697f89821a7ed31c6c672f6c06923bb53a681ebb203eabebb657bdafd80
SIZE (kvspb-nginx-auth-ldap-42d195d_GH0.tar.gz) = 18455
SHA256 (sto-ngx_http_auth_pam_module-v1.5.1_GH0.tar.gz) = 77676842919134af88a7b4bfca4470223e3a00d287d17c0dbdc9a114a685b6e7
diff --git a/www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config b/www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config
index 0d7aabe51d93..3afa4aaebd9c 100644
--- a/www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config
+++ b/www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config
@@ -1,9 +1,9 @@
---- ../spnego-http-auth-nginx-module-72c8ee0/config.orig 2020-10-17 22:35:57.676855000 +0200
-+++ ../spnego-http-auth-nginx-module-72c8ee0/config 2020-10-17 22:40:49.255324000 +0200
+--- ../spnego-http-auth-nginx-module-c626163/config.orig 2020-10-17 22:35:57.676855000 +0200
++++ ../spnego-http-auth-nginx-module-c626163/config 2020-10-17 22:40:49.255324000 +0200
@@ -1,8 +1,10 @@
ngx_addon_name=ngx_http_auth_spnego_module
-ngx_feature_libs="-lgssapi_krb5 -lkrb5 -lcom_err"
-+ngx_feature_libs="%%GSSAPILIBS%%"
++ngx_feature_libs="-L%%GSSAPILIBDIR%% %%GSSAPILIBS%%"
+ngx_module_incs="%%GSSAPINCDIR%%"
+