aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2013-02-13 09:23:58 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2013-02-13 09:23:58 +0000
commit9b451b1c38e64140284bcd94b2fb17b594295c75 (patch)
tree8d62ad8d632fc98442bb6d2ad55ace06dac945f2 /www/nginx
parent57e2e5ec84c9d9bc719c5d7abcbc4af5eebb9d00 (diff)
downloadports-9b451b1c38e64140284bcd94b2fb17b594295c75.tar.gz
ports-9b451b1c38e64140284bcd94b2fb17b594295c75.zip
Add nginx_pid_prefix rcvar for ability to prevent collision with other PIDs names
when using with profiles. Bump PORTREVISION. PR: 175823
Notes
Notes: svn path=/head/; revision=312147
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile1
-rw-r--r--www/nginx/files/nginx.in5
2 files changed, 5 insertions, 1 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index ede7001e17da..1eeafa41edd1 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.2.7
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
diff --git a/www/nginx/files/nginx.in b/www/nginx/files/nginx.in
index e1c413c2169c..c0765f6b676f 100644
--- a/www/nginx/files/nginx.in
+++ b/www/nginx/files/nginx.in
@@ -11,6 +11,9 @@
# Set it to "YES" to enable nginx
# nginx_profiles (str): Set to "" by default.
# Define your profiles here.
+# nginx_pid_prefix (str): Set to "" by default.
+# When using profiles manually assign value to "nginx_"
+# for prevent collision with other PIDs names.
# nginxlimits_enable (bool): Set to "NO" by default.
# Set it to yes to run `limits $limits_args`
# just before nginx starts.
@@ -47,7 +50,7 @@ load_rc_config $name
if [ -n "$2" ]; then
profile="$2"
if [ "x${nginx_profiles}" != "x" ]; then
- pidfile="${_pidprefix}/${profile}.pid"
+ pidfile="${_pidprefix}/${nginx_pid_prefix}${profile}.pid"
eval nginx_configfile="\${nginx_${profile}_configfile:-}"
if [ "x${nginx_configfile}" = "x" ]; then
echo "You must define a configuration file (nginx_${profile}_configfile)"