aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2012-09-19 18:29:13 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2012-09-19 18:29:13 +0000
commitf624c861669667b6d8f765f7d6f72f4f266381ab (patch)
tree6b666eedc3c5c6c5e04db14877e2b009d1a813e7 /www/nginx
parentce693ff742dd4e4072eaf931f90f78de933f4186 (diff)
downloadports-f624c861669667b6d8f765f7d6f72f4f266381ab.tar.gz
ports-f624c861669667b6d8f765f7d6f72f4f266381ab.zip
Fix rc script for nginx with profiles. (*)
Configure build with original http_dav if third-party http_dav_ext defined. Bump PORTREVISIONs. Found by: Slava Kokorin <slava.kokorin@gmail.com> (*)
Notes
Notes: svn path=/head/; revision=304538
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile4
-rw-r--r--www/nginx/files/nginx.in2
2 files changed, 4 insertions, 2 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 9401afc7d15e..0edae12bc1b7 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nginx
PORTVERSION= 1.2.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -334,11 +335,12 @@ DISTFILES+= agentzh-headers-more-nginx-module-v${NGINX_HEADERS_MORE_VERSION}-${G
CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-headers-more-nginx-module-${GIT_HEADERS_MORE_VERSION:S/^0-g//}
.endif
-.if ${PORT_OPTIONS:MHTTP_DAV}
+.if ${PORT_OPTIONS:MHTTP_DAV} || defined(USE_HTTP_DAV)
CONFIGURE_ARGS+=--with-http_dav_module
.endif
.if ${PORT_OPTIONS:MHTTP_DAV_EXT}
+USE_HTTP_DAV= yes
LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
NGINX_DAV_EXT_VERSION= 0.0.2
GIT_DAV_EXT_VERSION= 0-g0e07a3e
diff --git a/www/nginx/files/nginx.in b/www/nginx/files/nginx.in
index eb77986fb65c..e1c413c2169c 100644
--- a/www/nginx/files/nginx.in
+++ b/www/nginx/files/nginx.in
@@ -47,7 +47,7 @@ load_rc_config $name
if [ -n "$2" ]; then
profile="$2"
if [ "x${nginx_profiles}" != "x" ]; then
- pidfile="${_pidprefix}.${profile}.pid"
+ pidfile="${_pidprefix}/${profile}.pid"
eval nginx_configfile="\${nginx_${profile}_configfile:-}"
if [ "x${nginx_configfile}" = "x" ]; then
echo "You must define a configuration file (nginx_${profile}_configfile)"