aboutsummaryrefslogtreecommitdiff
path: root/www/nift
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-04-05 20:11:53 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-04-05 20:11:53 +0000
commitfd4edece110a4f0bfe8d9ac9e396773188f47d28 (patch)
tree458dd84ab9c13bd4f58d4d6c8755b83cb6486d20 /www/nift
parentabe77bfa0ca1c1aa89e95e86f1156e25e1ffb9f2 (diff)
downloadports-fd4edece110a4f0bfe8d9ac9e396773188f47d28.tar.gz
ports-fd4edece110a4f0bfe8d9ac9e396773188f47d28.zip
www/nift: Update to 2.2
- Update to 2.2 - Add files/patch-Makefile to use LuaJIT from ports - Patch Makefile for localbase PR: 244941 Submitted by: Mohammad S. Babaei (maintainer) Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D24298
Notes
Notes: svn path=/head/; revision=530832
Diffstat (limited to 'www/nift')
-rw-r--r--www/nift/Makefile9
-rw-r--r--www/nift/distinfo6
-rw-r--r--www/nift/files/patch-Makefile65
3 files changed, 75 insertions, 5 deletions
diff --git a/www/nift/Makefile b/www/nift/Makefile
index e6fee371343e..a1b473e7b7b7 100644
--- a/www/nift/Makefile
+++ b/www/nift/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nift
DISTVERSIONPREFIX= v
-DISTVERSION= 2.0.1
+DISTVERSION= 2.2
CATEGORIES= www
MAINTAINER= info@babaei.net
@@ -12,13 +12,18 @@ COMMENT= Cross-platform open source website generator
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c++11-lang
+LIB_DEPENDS= libluajit-5.1.so:lang/luajit
+
+USES= compiler:c++11-lang gmake
USE_GITHUB= yes
GH_ACCOUNT= nifty-site-manager
GH_PROJECT= nsm
PLIST_FILES= bin/nift \
bin/nsm
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/Makefile
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/nift
diff --git a/www/nift/distinfo b/www/nift/distinfo
index 62d757dfb5f6..f7584d91baaf 100644
--- a/www/nift/distinfo
+++ b/www/nift/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1578262769
-SHA256 (nifty-site-manager-nsm-v2.0.1_GH0.tar.gz) = 66aad5d280b7d7ea8a5ea5b6bee24a69883218df2bc455e7ffb60343b77d4e4a
-SIZE (nifty-site-manager-nsm-v2.0.1_GH0.tar.gz) = 53160
+TIMESTAMP = 1585525828
+SHA256 (nifty-site-manager-nsm-v2.2_GH0.tar.gz) = 65d0d597aa0de5683a63e3f0524e1aa5d99e081aeb3124624c612e55b49c54be
+SIZE (nifty-site-manager-nsm-v2.2_GH0.tar.gz) = 1201641
diff --git a/www/nift/files/patch-Makefile b/www/nift/files/patch-Makefile
new file mode 100644
index 000000000000..7d30dfdc14cc
--- /dev/null
+++ b/www/nift/files/patch-Makefile
@@ -0,0 +1,65 @@
+--- Makefile.orig 2020-03-29 23:58:44 UTC
++++ Makefile
+@@ -30,8 +30,7 @@ else ifeq ($(detected_OS),Windows) # Windows
+ else ifeq ($(detected_OS),FreeBSD) #FreeBSD
+ CXX=clang
+ CXXFLAGS+= -s -Qunused-arguments -lstdc++
+- LINK+= -ldl -lm -LLuaJIT/src -lluajit #use Nift built LuaJIT
+- #LINK+= -ldl -lm -L/usr/local/lib -lluajit-5.1 #use FreeBSD LuaJIT
++ LINK+= -ldl -lm -L%%LOCALBASE%%/lib -lluajit-5.1 #use FreeBSD LuaJIT
+ else # *nix
+ #use these flags for a smaller binary
+ #CXXFLAGS+= -s
+@@ -51,7 +50,7 @@ endif
+
+ ###
+
+-all: make-luajit nsm
++all: nsm
+
+ ###
+
+@@ -62,9 +61,6 @@ ifeq ($(detected_OS),Darwin) # Mac OSX
+ else ifeq ($(detected_OS),Windows) # Windows
+ cd LuaJIT && make
+ copy LuaJIT\src\lua51.dll .
+-else ifeq ($(detected_OS),FreeBSD) #FreeBSD
+- cd LuaJIT && gmake
+- cp LuaJIT/src/libluajit.so ./
+ else # *nix
+ cd LuaJIT && make
+ endif
+@@ -159,7 +155,6 @@ ifeq ($(detected_OS),Windows) # Windows
+ else ifeq ($(detected_OS),FreeBSD) #FreeBSD
+ mkdir -p ${BINDIR}
+ chmod 755 nsm
+- mv libluajit.so ${LIBDIR}/libluajit-5.1.so.2
+ mv nift ${BINDIR}
+ mv nsm ${BINDIR}
+ else # *nix
+@@ -175,7 +170,6 @@ ifeq ($(detected_OS),Windows) # Windows
+ @echo "and 'nift.exe' from install location, typically "
+ @echo "'C:\Windows\System32'"
+ else ifeq ($(detected_OS),FreeBSD) #FreeBSD
+- rm ${LIBDIR}/libluajit-5.1.so.2
+ rm ${BINDIR}/nift
+ rm ${BINDIR}/nsm
+ else # *nix
+@@ -201,7 +195,6 @@ else ifeq ($(detected_OS),Windows) # Windows
+ #cd LuaJIT && make clean #this doesn't work for some reason
+ else ifeq ($(detected_OS),FreeBSD) #FreeBSD
+ rm -f $(objects)
+- cd LuaJIT && gmake clean
+ else # *nix
+ rm -f $(objects)
+ cd LuaJIT && make clean
+@@ -215,8 +208,7 @@ else ifeq ($(detected_OS),Windows) # Windows
+ del -f $(objects) nsm.exe nift.exe lua51.dll
+ #cd LuaJIT && make clean #see same line for clean
+ else ifeq ($(detected_OS),FreeBSD) #FreeBSD
+- rm -f $(objects) nsm nift libluajit.so
+- cd LuaJIT && gmake clean
++ rm -f $(objects) nsm nift
+ else # *nix
+ rm -f $(objects) nsm nift
+ cd LuaJIT && make clean