aboutsummaryrefslogtreecommitdiff
path: root/www/node6/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-02-05 21:20:24 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-02-05 21:20:24 +0000
commit6d324c1f70c9ee4ebd41f6a689ac379f8d47927b (patch)
tree7c63a95968ed9b4eb610fca1b72ff17c7d9581c2 /www/node6/Makefile
parent2da0cd8de2b6a439333303b69967925ed04914ad (diff)
downloadports-6d324c1f70c9ee4ebd41f6a689ac379f8d47927b.tar.gz
ports-6d324c1f70c9ee4ebd41f6a689ac379f8d47927b.zip
- Remove inclusion of bsd.default-versions.mk from ftp/curl/Makefile so
bsd.default-versions.mk can rely on ARCH being defined. - In bsd.port.mk move inclusion of bsd.default-versions.mk from the pre-makefile section to the options section so the variables can be used earlier. Also put the bit of code sitting between the options section and the pre-makefile section into the options section. - Remove last few cases where ports set WITH_OPENSSL_PORT. This variable is handled in bsd.default-versions.mk and some ports were setting it after including bsd.port.options.mk. After FreeBSD 9 EoL all but a few ports, and then only when setting non-default options, work without setting that variable. PR: 215996 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=433456
Diffstat (limited to 'www/node6/Makefile')
-rw-r--r--www/node6/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/www/node6/Makefile b/www/node6/Makefile
index 5b0b9d13365a..b16436ed1977 100644
--- a/www/node6/Makefile
+++ b/www/node6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= node
PORTVERSION= 6.9.5
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
PKGNAMESUFFIX= 6
@@ -14,7 +15,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS DTRACE
-OPTIONS_DEFAULT= DTRACE
+OPTIONS_DEFAULT=BUNDLED_SSL DTRACE
OPTIONS_SUB= yes
.if !exists(/usr/sbin/dtrace)
@@ -58,21 +59,18 @@ LIB_DEPENDS+= libcares.so:dns/c-ares\
.if empty(PORT_OPTIONS:MBUNDLED_SSL)
-.if ${OSVERSION} < 1100085
-# node.js requires openssl 1.0.2, use the port since base isn't new enough
-WITH_OPENSSL_PORT= yes
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100085 && ${SSL_DEFAULT} == base
+IGNORE= node.js requires openssl 1.0.2, add DEFAULT_VERSIONS+=ssl=openssl to /etc/make.conf or enable BUNDLED_SSL option
.endif
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if empty(PORT_OPTIONS:MBUNDLED_SSL)
.if !empty(SSL_DEFAULT:Mlibressl*)
IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
.endif
+
.endif
+.include <bsd.port.pre.mk>
+
.if ${ARCH} == "armv6"
CONFIGURE_ARGS+=--openssl-no-asm
.endif