aboutsummaryrefslogtreecommitdiff
path: root/www/node8
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2019-03-29 04:57:05 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2019-03-29 04:57:05 +0000
commit32926c7289fba7b87b4999a7c6054cbd449eb67f (patch)
treefd44da4b8781f15efba44f71c7790479c4547385 /www/node8
parent19f0bd96bab155cf24bffe00c274b11b5c8fb0a2 (diff)
downloadports-32926c7289fba7b87b4999a7c6054cbd449eb67f.tar.gz
ports-32926c7289fba7b87b4999a7c6054cbd449eb67f.zip
www/node*: specify minimum versions of dependencies in BUILD_DEPENDS
Add BUILD_DEPENDS for all LIB_DEPENDS, specifying the minimum version as the version bundled with a particlar version of Node.js. This should help people building from ports with out-of-date dependencies with a helpful message instead of build failures. Reported by: freebsd-ports@ Sponsored by: Miles AS
Notes
Notes: svn path=/head/; revision=497067
Diffstat (limited to 'www/node8')
-rw-r--r--www/node8/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/node8/Makefile b/www/node8/Makefile
index 9884b5f44720..58b8c769e41c 100644
--- a/www/node8/Makefile
+++ b/www/node8/Makefile
@@ -38,6 +38,7 @@ BUNDLED_SSL_CONFIGURE_OFF= --shared-openssl --openssl-use-def-ca-store
BUNDLED_SSL_RUN_DEPENDS_OFF= ca_root_nss>=0:security/ca_root_nss
NLS_CONFIGURE_ON= --with-intl=system-icu
+NLS_BUILD_DEPENDS= icu>=60.1:devel/icu
NLS_LIB_DEPENDS= libicui18n.so:devel/icu
DTRACE_CONFIGURE_ON= --with-dtrace
@@ -64,6 +65,9 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
CXX.host=${CXX} CXXFLAGS.host="${CXXFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
+BUILD_DEPENDS+= c-ares>=1.10.0:dns/c-ares\
+ libuv>1.23.2:devel/libuv \
+ libnghttp2>=1.33.0:www/libnghttp2
LIB_DEPENDS+= libcares.so:dns/c-ares\
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2