aboutsummaryrefslogtreecommitdiff
path: root/www/obhttpd/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-12-06 15:41:37 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-12-06 15:41:37 +0000
commit199baf86acb168a66a4a80f39024b6c685fb2807 (patch)
treecf966abe79db20bd84649c143d7e0b9895c48fd7 /www/obhttpd/Makefile
parentd9014a7bbfccdf0011ccbf026eae06f18de19318 (diff)
downloadports-199baf86acb168a66a4a80f39024b6c685fb2807.tar.gz
ports-199baf86acb168a66a4a80f39024b6c685fb2807.zip
Move www/httpd to www/openhttpd to avoid consistency issues
- Move to www/obhttpd - Avoid config file name conflict: httpd.conf -> obhttpd.conf PR: 198705
Notes
Notes: svn path=/head/; revision=403117
Diffstat (limited to 'www/obhttpd/Makefile')
-rw-r--r--www/obhttpd/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/www/obhttpd/Makefile b/www/obhttpd/Makefile
new file mode 100644
index 000000000000..4a93b36226b0
--- /dev/null
+++ b/www/obhttpd/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= obhttpd
+PORTVERSION= 5.7.20150508
+CATEGORIES= www
+
+MAINTAINER= koue@chaosophia.net
+COMMENT= OpenBSD http server
+
+LICENSE= BSD3CLAUSE
+
+WRKSRC= ${WRKDIR}/${GH_PROJECT}-${PORTVERSION}/src/usr.sbin/${GH_PROJECT}
+
+USE_GITHUB= yes
+GH_ACCOUNT= koue
+GH_PROJECT= httpd
+
+USE_OPENSSL= yes
+USE_RC_SUBR= obhttpd
+
+WITH_OPENSSL_PORT=yes
+OPENSSL_PORT= security/libressl
+
+CFLAGS+= -Wall
+
+MAKE_ARGS+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
+
+USERS= www
+GROUPS= www
+
+PLIST_FILES= sbin/obhttpd \
+ man/man5/obhttpd.conf.5.gz \
+ man/man8/obhttpd.8.gz
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|httpd$$|obhttpd|g' \
+ -e 's|httpd.conf.5|obhttpd.conf.5|g' \
+ -e 's|httpd.8|obhttpd.8|g' ${WRKSRC}/Makefile
+ ${MV} ${WRKSRC}/httpd.conf.5 ${WRKSRC}/obhttpd.conf.5
+ ${MV} ${WRKSRC}/httpd.8 ${WRKSRC}/obhttpd.8
+ ${REINPLACE_CMD} -e 's|/etc/httpd.conf|${PREFIX}/etc/obhttpd.conf|g' \
+ ${WRKSRC}/httpd.h
+
+.include <bsd.port.mk>