aboutsummaryrefslogtreecommitdiff
path: root/www/otrs
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-05-15 13:37:05 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-05-15 13:37:05 +0000
commitcb539c5c7f28eec62286f6f1ff8c98fc6bbb52fe (patch)
tree6307d16c6c6ec92b746e9c83d46b83601ae6c860 /www/otrs
parent303fad494ee1f93ad7260930d25ad2909c696ace (diff)
downloadports-cb539c5c7f28eec62286f6f1ff8c98fc6bbb52fe.tar.gz
ports-cb539c5c7f28eec62286f6f1ff8c98fc6bbb52fe.zip
www/otrs: add missing dependencies, and missing DBUpdateTo6 scripts
- Add missing dependencies - Attempt to run otrs.SetPermissions.pl script on install. It is going to work if there is an existing otrs user from the previous installation. Users installing the port for the first time should run it manually as stated in pkg-message. - Install DBUpdateTo6 scripts PR: 227924, 228106 Reported by: jonaspalm@posteo.de Submitted by: m.tsatsenko@gmail.com (maintainer), Felix J. Ogris <fjo@ogris.de>
Notes
Notes: svn path=/head/; revision=470015
Diffstat (limited to 'www/otrs')
-rw-r--r--www/otrs/Makefile18
-rw-r--r--www/otrs/files/pkg-message.in3
-rw-r--r--www/otrs/pkg-plist58
3 files changed, 69 insertions, 10 deletions
diff --git a/www/otrs/Makefile b/www/otrs/Makefile
index 0b6e0637a4af..b0d3b416e8bf 100644
--- a/www/otrs/Makefile
+++ b/www/otrs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= otrs
PORTVERSION= 6.0.6
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= m.tsatsenko@gmail.com
@@ -43,7 +44,9 @@ BUILD_DEPENDS= p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
p5-CGI>=0:www/p5-CGI \
p5-Lingua-Translit>=0:devel/p5-Lingua-Translit \
p5-Pod-Strip>=0:textproc/p5-Pod-Strip \
- p5-Template-Toolkit>=0:www/p5-Template-Toolkit
+ p5-Template-Toolkit>=0:www/p5-Template-Toolkit \
+ p5-XML-LibXML>=0:textproc/p5-XML-LibXML \
+ p5-Sisimai>=0:mail/p5-Sisimai
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= cpe shebangfix perl5 tar:bzip2
@@ -169,16 +172,15 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/scripts/database/*.* ${STAGEDIR}${OTRSDIR}/scripts/database/
${INSTALL_SCRIPT} ${WRKSRC}/scripts/test/*.t ${STAGEDIR}${OTRSDIR}/scripts/test/
${INSTALL_SCRIPT} ${WRKSRC}/scripts/tools/*.pl ${STAGEDIR}${OTRSDIR}/scripts/tools/
+ (cd ${WRKSRC}/scripts && ${PAX} -r -w DBUpdateTo6 ${STAGEDIR}${OTRSDIR}/scripts)
${FIND} ${CRON_SCRIPTS} -type f -name *.dist | ${SED} -e "p;s/\.dist//" | ${XARGS} -n2 ${MV}
${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/var/article
${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/var/httpd/htdocs/js/js-cache/
${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/var/tmp
-
-# otrs.SetPermissions.pl does not work in stage environment due to missing otrs user
-#post-install:
-# cd ${STAGEDIR}/${OTRSDIR} && ${PERL} ./bin/otrs.SetPermissions.pl \
-# --web-group=${WWWOWN} \
-# --otrs-user=${PORTNAME} \
-# --admin-group=wheel ${STAGEDIR}${OTRSDIR}
+ # Attemt to set permissions for OTRS. It will fail if there is no pre-existing otrs user
+ cd ${STAGEDIR}/${OTRSDIR} && ${PERL} ./bin/otrs.SetPermissions.pl \
+ --web-group=${WWWOWN} \
+ --otrs-user=${PORTNAME} \
+ --admin-group=wheel ${STAGEDIR}${OTRSDIR} || true
.include <bsd.port.post.mk>
diff --git a/www/otrs/files/pkg-message.in b/www/otrs/files/pkg-message.in
index bfed54315b6b..0ff56582ee14 100644
--- a/www/otrs/files/pkg-message.in
+++ b/www/otrs/files/pkg-message.in
@@ -8,7 +8,8 @@ and/or documentation in %%DOCSDIR%% for further instructions, particularly
regarding configuring your web server, database, cron scripts, and
receiving emails.
-Do not forget to run otrs.SetPermissions.pl script.
+Do not forget to run otrs.SetPermissions.pl script when installing OTRS
+for the first time.
For example:
# %%PREFIX%%/otrs/bin/otrs.SetPermissions.pl \
--web-group=%%WWWOWN%% --otrs-user=%%OTRS_USER%% \
diff --git a/www/otrs/pkg-plist b/www/otrs/pkg-plist
index ca6c5532b8ed..7186d0153215 100644
--- a/www/otrs/pkg-plist
+++ b/www/otrs/pkg-plist
@@ -1,4 +1,4 @@
-@owner %%OTRS_USER%%
+@owner otrs
@group %%WWWOWN%%
@sample otrs/.fetchmailrc.dist otrs/.fetchmailrc
@sample otrs/.mailfilter.dist otrs/.mailfilter
@@ -1301,6 +1301,62 @@ otrs/bin/otrs.PostMaster.pl
otrs/bin/otrs.SetPermissions.pl
otrs/scripts/DBUpdate-to-6.pl
otrs/scripts/DBUpdateTo6.pm
+otrs/scripts/DBUpdateTo6/AddAppointmentCalendarNotification.pm
+otrs/scripts/DBUpdateTo6/Base.pm
+otrs/scripts/DBUpdateTo6/CacheCleanup.pm
+otrs/scripts/DBUpdateTo6/CleanGroupUserPermissionValue.pm
+otrs/scripts/DBUpdateTo6/CreateAppointmentCalendarTables.pm
+otrs/scripts/DBUpdateTo6/CreateFormDraftTables.pm
+otrs/scripts/DBUpdateTo6/CreateTicketNumberCounterTables.pm
+otrs/scripts/DBUpdateTo6/DatabaseBackupCheck.pm
+otrs/scripts/DBUpdateTo6/DatabaseCharsetCheck.pm
+otrs/scripts/DBUpdateTo6/DatabaseVersionCheck.pm
+otrs/scripts/DBUpdateTo6/DropObjectLockState.pm
+otrs/scripts/DBUpdateTo6/FrameworkVersionCheck.pm
+otrs/scripts/DBUpdateTo6/InitializeDefaultCronjobs.pm
+otrs/scripts/DBUpdateTo6/MigrateChatData.pm
+otrs/scripts/DBUpdateTo6/MigrateArticleData.pm
+otrs/scripts/DBUpdateTo6/MigrateArticleSearchIndex.pm
+otrs/scripts/DBUpdateTo6/MigrateConfigEffectiveValues.pm
+otrs/scripts/DBUpdateTo6/MigrateGenericAgentJobs.pm
+otrs/scripts/DBUpdateTo6/MigratePackageRepositoryConfiguration.pm
+otrs/scripts/DBUpdateTo6/MigratePossibleNextActions.pm
+otrs/scripts/DBUpdateTo6/MigratePostMasterData.pm
+otrs/scripts/DBUpdateTo6/MigrateProcessManagementData.pm
+otrs/scripts/DBUpdateTo6/MigrateTicketAppointments.pm
+otrs/scripts/DBUpdateTo6/MigrateTicketFrontendCustomerInfoZoom.pm
+otrs/scripts/DBUpdateTo6/MigrateTicketMergedHistory.pm
+otrs/scripts/DBUpdateTo6/MigrateTicketNotifications.pm
+otrs/scripts/DBUpdateTo6/TaskConfig/MigrateArticleData.yml.dist
+otrs/scripts/DBUpdateTo6/MigrateTicketStats.pm
+otrs/scripts/DBUpdateTo6/MigrateTicketStorageModule.pm
+otrs/scripts/DBUpdateTo6/MigrateTimeZoneConfiguration.pm
+otrs/scripts/DBUpdateTo6/MigrateWebServiceConfiguration.pm
+otrs/scripts/DBUpdateTo6/MigrateZoomExpandConfig.pm
+otrs/scripts/DBUpdateTo6/PerlModulesCheck.pm
+otrs/scripts/DBUpdateTo6/PerlVersionCheck.pm
+otrs/scripts/DBUpdateTo6/PostArticleTableStructureChanges.pm
+otrs/scripts/DBUpdateTo6/RebuildConfig.pm
+otrs/scripts/DBUpdateTo6/SysConfigCheck.pm
+otrs/scripts/DBUpdateTo6/UninstallMergedFeatureAddOns.pm
+otrs/scripts/DBUpdateTo6/UpdateAppointmentCalendarFutureTasks.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/ArticleTableChangesPostRename.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/ArticleTableChangesPreRename.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/ArticleTableChangesRename.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/CommunicationLogs.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/DynamicFieldChanges.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/NewArticleSearchIndexTable.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/NewChatDataTable.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/NewCommunicationChannelTable.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/NewCustomerRelationTables.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/NewSysconfigTables.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/PasswordColumnChanges.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/RemoveMD5Columns.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/TicketDropCreateTimeUnix.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/TicketHistoryTableChanges.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/TicketIndexUpdate.pm
+otrs/scripts/DBUpdateTo6/UpgradeDatabaseStructure/UpdateNotificationTables.pm
otrs/scripts/apache2-httpd-plack-proxy.conf
otrs/scripts/apache2-httpd.include.conf
otrs/scripts/apache2-perl-startup.pl