aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Acme-Monta/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-07-28 16:22:46 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-07-28 16:22:46 +0000
commit44d413ff74cac09fab68d58cac994a67b8040829 (patch)
tree7908fa3391a5c80158a8d8f60000b84fa6eaa0ed /www/p5-Acme-Monta/Makefile
parent620ffa4735d9e08758bb257b5834a07cf22f1836 (diff)
downloadports-44d413ff74cac09fab68d58cac994a67b8040829.tar.gz
ports-44d413ff74cac09fab68d58cac994a67b8040829.zip
- fix '$VERSION' and unbreak this port on perl-5.00503
PR: 84174 Submitted by: leeym Approved by: TAKAHASHI Kaoru <kaoru@kaisei.org>
Notes
Notes: svn path=/head/; revision=140329
Diffstat (limited to 'www/p5-Acme-Monta/Makefile')
-rw-r--r--www/p5-Acme-Monta/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/p5-Acme-Monta/Makefile b/www/p5-Acme-Monta/Makefile
index 3268a16bada0..07462b5ae272 100644
--- a/www/p5-Acme-Monta/Makefile
+++ b/www/p5-Acme-Monta/Makefile
@@ -19,4 +19,12 @@ PERL_CONFIGURE= yes
MAN3= Acme::Monta.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' \
+ ${WRKSRC}/lib/Acme/Monta.pm
+.endif
+
+.include <bsd.port.post.mk>