aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Session-Wrapper/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-10-12 11:32:32 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-10-12 11:32:32 +0000
commite69c4b52654537293a02a1b52fd755f8c8ccbe9a (patch)
tree23faa1ff2dcef62bcfc6b0132287f26fce171b92 /www/p5-Apache-Session-Wrapper/Makefile
parent733a2edd02acfafb2046dcfb5388100d2bce4a50 (diff)
downloadports-e69c4b52654537293a02a1b52fd755f8c8ccbe9a.tar.gz
ports-e69c4b52654537293a02a1b52fd755f8c8ccbe9a.zip
Add p5-Apache-Session-Wrapper 0.17, a simple wrapper around
Apache::Session.
Notes
Notes: svn path=/head/; revision=118960
Diffstat (limited to 'www/p5-Apache-Session-Wrapper/Makefile')
-rw-r--r--www/p5-Apache-Session-Wrapper/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/p5-Apache-Session-Wrapper/Makefile b/www/p5-Apache-Session-Wrapper/Makefile
new file mode 100644
index 000000000000..6024625fe658
--- /dev/null
+++ b/www/p5-Apache-Session-Wrapper/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Apache-Session-Wrapper
+# Date created: 20 Sep 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Session-Wrapper
+PORTVERSION= 0.17
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= A simple wrapper around Apache::Session
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Container.pm:${PORTSDIR}/devel/p5-Class-Container \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Apache::Session::Wrapper.3
+
+.include <bsd.port.pre.mk>
+
+# Depends on devel/p5-Class-Container whichs needs perl 5.6.x or later
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>