aboutsummaryrefslogtreecommitdiff
path: root/www/p5-B-LexInfo/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-14 12:01:19 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-14 12:01:19 +0000
commit5cd5c67643ecbd1a5b21b348b5599003b9406cc2 (patch)
tree3a2aa4a2a98db7e2ea27891721368a4a0a375fd6 /www/p5-B-LexInfo/Makefile
parentfc2b027cc04b35946da388bb2a5a9a648730e1a8 (diff)
downloadports-5cd5c67643ecbd1a5b21b348b5599003b9406cc2.tar.gz
ports-5cd5c67643ecbd1a5b21b348b5599003b9406cc2.zip
Add p5-B-LexInfo 0.02,
Show information about subroutine lexical variables. PR: 57921 Submitted by: Trevor S. Cornpropst <tcornpropst@cox.net>
Notes
Notes: svn path=/head/; revision=91175
Diffstat (limited to 'www/p5-B-LexInfo/Makefile')
-rw-r--r--www/p5-B-LexInfo/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/p5-B-LexInfo/Makefile b/www/p5-B-LexInfo/Makefile
new file mode 100644
index 000000000000..5a44168451f1
--- /dev/null
+++ b/www/p5-B-LexInfo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: B-LexInfo
+# Date Created: 08 Oct 2003
+# Whom: Trevor S. Cornpropst <tcornpropst@cox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= B-LexInfo
+PORTVERSION= 0.02
+CATEGORIES= www devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= B
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tcornpropst@cox.net
+COMMENT= Show information about subroutine lexical variables
+
+.if defined(WITH_MODPERL2)
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/mod_perl.pm:${PORTSDIR}/www/mod_perl2
+.else
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+.endif
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= B::LexInfo.3 Apache::RegistryLexInfo.3
+
+.include <bsd.port.mk>