aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CSS-DOM/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:46:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:46:00 +0000
commit5c52aa712570a0c285785ca446cf5d1a7da4b060 (patch)
tree002dfb4a812a81694f62e7939bd18d6111de84bf /www/p5-CSS-DOM/Makefile
parenta4bb32a2aa0f4e8f0019f4b8c9bfbf368b3f3350 (diff)
downloadports-5c52aa712570a0c285785ca446cf5d1a7da4b060.tar.gz
ports-5c52aa712570a0c285785ca446cf5d1a7da4b060.zip
This module provides the CSS-specific interfaces described in the W3C
DOM recommendation. The CSS::DOM class itself implements the StyleSheet and CSSStyleSheet DOM interfaces. WWW: http://search.cpan.org/dist/CSS-DOM/ PR: ports/128901 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=223150
Diffstat (limited to 'www/p5-CSS-DOM/Makefile')
-rw-r--r--www/p5-CSS-DOM/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/www/p5-CSS-DOM/Makefile b/www/p5-CSS-DOM/Makefile
new file mode 100644
index 000000000000..79fa21e74527
--- /dev/null
+++ b/www/p5-CSS-DOM/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-CSS-DOM
+# Date created: 2008-11-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CSS-DOM
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CSS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Document Object Model for Cascading Style Sheets
+
+RUN_DEPENDS= p5-constant-lexical>0:${PORTSDIR}/devel/p5-constant-lexical
+
+PERL_CONFIGURE= yes
+USE_PERL5= 5.8.8+
+
+MAN3= CSS::DOM.3 \
+ CSS::DOM::Array.3 \
+ CSS::DOM::Exception.3 \
+ CSS::DOM::Interface.3 \
+ CSS::DOM::MediaList.3 \
+ CSS::DOM::Parser.3 \
+ CSS::DOM::Rule.3 \
+ CSS::DOM::Rule::FontFace.3 \
+ CSS::DOM::Rule::Import.3 \
+ CSS::DOM::Rule::Media.3 \
+ CSS::DOM::Rule::Page.3 \
+ CSS::DOM::Rule::Style.3 \
+ CSS::DOM::RuleList.3 \
+ CSS::DOM::Style.3 \
+ CSS::DOM::StyleSheetList.3 \
+ CSS::DOM::Value.3 \
+ CSS::DOM::Value::Primitive.3
+
+.include <bsd.port.mk>