aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-C3/Makefile
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-04-06 08:22:14 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-04-06 08:22:14 +0000
commit5614f52405294b4a972b765652b7e2cbf54b0879 (patch)
tree1302036f3c373ee40d339daec50b65a32d6777da /www/p5-Catalyst-Plugin-C3/Makefile
parente01990ca641933f930ab4f1bd37aaa590cb835fa (diff)
downloadports-5614f52405294b4a972b765652b7e2cbf54b0879.tar.gz
ports-5614f52405294b4a972b765652b7e2cbf54b0879.zip
New port: www/p5-Catalyst-Plugin-C3, Catalyst Plugin to subvert NEXT to use Class::C3
Notes
Notes: svn path=/head/; revision=189346
Diffstat (limited to 'www/p5-Catalyst-Plugin-C3/Makefile')
-rw-r--r--www/p5-Catalyst-Plugin-C3/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-C3/Makefile b/www/p5-Catalyst-Plugin-C3/Makefile
new file mode 100644
index 000000000000..cdb27a0d80ce
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-C3/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-C3
+# Date created: Apr 6, 2007
+# Whom: lbr@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-C3
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Catalyst Plugin to subvert NEXT to use Class::C3
+
+BUILD_DEPENDS= p5-Algorithm-C3>=0.06:${PORTSDIR}/devel/p5-Algorithm-C3 \
+ p5-Catalyst-Runtime>=5.7006:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Class-C3>=0.14:${PORTSDIR}/devel/p5-Class-C3
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::C3.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>