aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-SubRequest/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-05-11 09:54:05 +0000
committerLars Thegler <lth@FreeBSD.org>2005-05-11 09:54:05 +0000
commitd9a0fbfc59ad213386323235037b6bbb3515b8cb (patch)
treedae8991b6f6e3ed064f5bcfec88f1a55ec93bbd5 /www/p5-Catalyst-Plugin-SubRequest/Makefile
parent5ff603dbf2ea5af2ad04cd71c311c946e188ad7b (diff)
downloadports-d9a0fbfc59ad213386323235037b6bbb3515b8cb.tar.gz
ports-d9a0fbfc59ad213386323235037b6bbb3515b8cb.zip
Add p5-Catalyst-Plugin-SubRequest 0.04, make subrequests to actions in
Catalyst. PR: ports/80719 Submitted by: Travis Campbell <hcoyote@ghostar.org>
Notes
Notes: svn path=/head/; revision=135039
Diffstat (limited to 'www/p5-Catalyst-Plugin-SubRequest/Makefile')
-rw-r--r--www/p5-Catalyst-Plugin-SubRequest/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-SubRequest/Makefile b/www/p5-Catalyst-Plugin-SubRequest/Makefile
new file mode 100644
index 000000000000..4aa8e27948c7
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-SubRequest/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: p5-Catalyst-Plugin-SubRequest
+# Date created: May 6, 2005
+# Whom: Travis Campbell <hcoyote@ghostar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-SubRequest
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MR/MRAMBERG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hcoyote@ghostar.org
+COMMENT= Make subrequests to actions in Catalyst
+
+BUILD_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::SubRequest.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>