aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Runtime/Makefile
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2006-07-11 17:31:00 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2006-07-11 17:31:00 +0000
commitd213f1c3bb68b3f3a14e6e063b669bff3b610e57 (patch)
treeccf7ba78b1e6de2bc7e597dbe978ab237d32ba86 /www/p5-Catalyst-Runtime/Makefile
parent82a394ce9a945267bfb8fd8cbf50cd1479f9c33c (diff)
downloadports-d213f1c3bb68b3f3a14e6e063b669bff3b610e57.tar.gz
ports-d213f1c3bb68b3f3a14e6e063b669bff3b610e57.zip
New port, www/p5-Catalyst-Runtime, The Elegant MVC Web Application Framework (Runtime)
p5-Catalyst has been split - this is the runtime part.
Notes
Notes: svn path=/head/; revision=167499
Diffstat (limited to 'www/p5-Catalyst-Runtime/Makefile')
-rw-r--r--www/p5-Catalyst-Runtime/Makefile107
1 files changed, 107 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Runtime/Makefile b/www/p5-Catalyst-Runtime/Makefile
new file mode 100644
index 000000000000..6fff2f9a3912
--- /dev/null
+++ b/www/p5-Catalyst-Runtime/Makefile
@@ -0,0 +1,107 @@
+# Ports collection makefile for: p5-Catalyst-Runtime
+# Date created: Jul 8, 2006
+# Whom: lbr
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Runtime
+PORTVERSION= 5.7000
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= The Elegant MVC Web Application Framework (Runtime)
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Class-Inspector>=1.06:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-CGI-Simple>=0:${PORTSDIR}/www/p5-CGI-Simple \
+ p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-File-Modified>=0:${PORTSDIR}/devel/p5-File-Modified \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTTP-Body>=0.5:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
+ p5-HTTP-Request-AsCGI>=0.5:${PORTSDIR}/www/p5-HTTP-Request-AsCGI \
+ p5-Module-Pluggable>=3.01:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-NEXT>=0:${PORTSDIR}/devel/p5-NEXT \
+ p5-Path-Class>=0.09:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Text-SimpleTable>=0.03:${PORTSDIR}/textproc/p5-Text-SimpleTable \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes \
+ p5-Tree-Simple>=1.15:${PORTSDIR}/devel/p5-Tree-Simple \
+ p5-Tree-Simple-VisitorFactory>=0:${PORTSDIR}/devel/p5-Tree-Simple-VisitorFactory \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-Module-Install>=0.63:${PORTSDIR}/devel/p5-Module-Install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= catalyst.pl.1
+MAN3= Catalyst.3 \
+ Catalyst::Action.3 \
+ Catalyst::ActionChain.3 \
+ Catalyst::ActionContainer.3 \
+ Catalyst::AttrContainer.3 \
+ Catalyst::Base.3 \
+ Catalyst::Build.3 \
+ Catalyst::Component.3 \
+ Catalyst::Controller.3 \
+ Catalyst::DispatchType.3 \
+ Catalyst::DispatchType::Chained.3 \
+ Catalyst::DispatchType::Default.3 \
+ Catalyst::DispatchType::Index.3 \
+ Catalyst::DispatchType::Path.3 \
+ Catalyst::DispatchType::Regex.3 \
+ Catalyst::Dispatcher.3 \
+ Catalyst::Engine.3 \
+ Catalyst::Engine::CGI.3 \
+ Catalyst::Engine::FastCGI.3 \
+ Catalyst::Engine::HTTP.3 \
+ Catalyst::Engine::HTTP::Restarter.3 \
+ Catalyst::Engine::HTTP::Restarter::Watcher.3 \
+ Catalyst::Exception.3 \
+ Catalyst::Log.3 \
+ Catalyst::Manual.3 \
+ Catalyst::Manual::About.3 \
+ Catalyst::Manual::Actions.3 \
+ Catalyst::Manual::Cookbook.3 \
+ Catalyst::Manual::DevelopmentProcess.3 \
+ Catalyst::Manual::Installation.3 \
+ Catalyst::Manual::Installation::CentOS4.3 \
+ Catalyst::Manual::Internals.3 \
+ Catalyst::Manual::Intro.3 \
+ Catalyst::Manual::Plugins.3 \
+ Catalyst::Manual::Tutorial.3 \
+ Catalyst::Manual::Tutorial::AdvancedCRUD.3 \
+ Catalyst::Manual::Tutorial::Appendices.3 \
+ Catalyst::Manual::Tutorial::Authentication.3 \
+ Catalyst::Manual::Tutorial::Authorization.3 \
+ Catalyst::Manual::Tutorial::BasicCRUD.3 \
+ Catalyst::Manual::Tutorial::CatalystBasics.3 \
+ Catalyst::Manual::Tutorial::Debugging.3 \
+ Catalyst::Manual::Tutorial::Intro.3 \
+ Catalyst::Manual::Tutorial::Testing.3 \
+ Catalyst::Manual::WritingPlugins.3 \
+ Catalyst::Model.3 \
+ Catalyst::Request.3 \
+ Catalyst::Request::Upload.3 \
+ Catalyst::Response.3 \
+ Catalyst::Runtime.3 \
+ Catalyst::Test.3 \
+ Catalyst::Utils.3 \
+ Catalyst::View.3
+
+post-install:
+ @${CAT} pkg-message
+
+post-extract:
+ @${PERL} -i.bak -ne 'print unless m,^feature, .. m,;$$,' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>