aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-View-Email/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 08:08:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 08:08:05 +0000
commita2d01192d59afe028d6e33b6a1f8fba0a225600a (patch)
tree89357a89afb0b26745a9173f47049887bb9a866f /www/p5-Catalyst-View-Email/Makefile
parent19e8252e6524c6552a6344163be3a81954f4dc11 (diff)
downloadports-a2d01192d59afe028d6e33b6a1f8fba0a225600a.tar.gz
ports-a2d01192d59afe028d6e33b6a1f8fba0a225600a.zip
[NEW PORT] www/p5-Catalyst-View-Email: Catalyst View for Email
Catalyst::Helper::View::Email - Helper for Email Views WWW: http://search.cpan.org/dist/Catalyst-View-Email/ PR: ports/113319 Submitted by: Tomoyuki Sakurai <cherry@trombik.org>
Notes
Notes: svn path=/head/; revision=199009
Diffstat (limited to 'www/p5-Catalyst-View-Email/Makefile')
-rw-r--r--www/p5-Catalyst-View-Email/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/p5-Catalyst-View-Email/Makefile b/www/p5-Catalyst-View-Email/Makefile
new file mode 100644
index 000000000000..16d7419afb68
--- /dev/null
+++ b/www/p5-Catalyst-View-Email/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Catalyst-View-Email
+# Date created: 2007-06-04
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-View-Email
+PORTVERSION= 0.01
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cherry@trombik.org
+COMMENT= Catalyst View for Email
+
+RUN_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Catalyst-Devel>=1.00:${PORTSDIR}/www/p5-Catalyst-Devel \
+ p5-Catalyst-View-TT>0:${PORTSDIR}/www/p5-Catalyst-View-TT \
+ p5-Class-C3>=0:${PORTSDIR}/devel/p5-Class-C3 \
+ p5-Email-Send>=2.185:${PORTSDIR}/mail/p5-Email-Send \
+ mail/p5-Email-MIME>=1.859:${PORTSDIR}/mail/p5-Email-MIME \
+ mail/p5-Email-MIME-Creator>=1.45:${PORTSDIR}/mail/p5-Email-MIME-Creator
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Helper::View::Email.3 Catalyst::Helper::View::Email::Template.3 \
+ Catalyst::View::Email.3 Catalyst::View::Email::Template.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>