aboutsummaryrefslogtreecommitdiff
path: root/www/p5-ClearSilver/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-06-30 06:01:33 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-06-30 06:01:33 +0000
commitdaa85ff37bc4884003340a548fd85f4d89f97398 (patch)
tree5a53fc5b7c5fec9b0f4b45d7b1991f5e1f29abd2 /www/p5-ClearSilver/Makefile
parentd3812f9aeeab67f3cea13fd16bae914f9584d8aa (diff)
downloadports-daa85ff37bc4884003340a548fd85f4d89f97398.tar.gz
ports-daa85ff37bc4884003340a548fd85f4d89f97398.zip
Add p5-ClearSilver 0.10.3, perl bindings for fast and powerful template
system. PR: ports/99445 Submitted by: rink
Notes
Notes: svn path=/head/; revision=166647
Diffstat (limited to 'www/p5-ClearSilver/Makefile')
-rw-r--r--www/p5-ClearSilver/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-ClearSilver/Makefile b/www/p5-ClearSilver/Makefile
new file mode 100644
index 000000000000..57f9e29a152e
--- /dev/null
+++ b/www/p5-ClearSilver/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-ClearSilver
+# Date created: June 25, 2006
+# Whom: Rink Springer <rink@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ClearSilver
+PORTVERSION= 0.10.3
+CATEGORIES= www perl5
+MASTER_SITES= http://www.clearsilver.net/downloads/
+PKGNAMEPREFIX= p5-
+DISTNAME= clearsilver-${PORTVERSION}
+
+MAINTAINER= rink@FreeBSD.org
+COMMENT= Perl bindings for fast and powerful template system
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/cstest:${PORTSDIR}/www/clearsilver
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/perl
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC="-I${LOCALBASE}/include/ClearSilver"
+
+MAN3= ClearSilver.3
+
+.include <bsd.port.mk>