aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer-Plugin-Lexicon/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-10 22:41:40 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-10 22:41:40 +0000
commit3857791e2b547c2be0e82c50ca72d58596cecff1 (patch)
treeb8177e7bdc5a9fcf559596343f9a47f7ce395e43 /www/p5-Dancer-Plugin-Lexicon/Makefile
parentcc555442337c7591ab5c3fd19ad8e3e185a256b0 (diff)
downloadports-3857791e2b547c2be0e82c50ca72d58596cecff1.tar.gz
ports-3857791e2b547c2be0e82c50ca72d58596cecff1.zip
Add new port www/p5-Dancer-Plugin-Lexicon
PR: 192352 Submitted by: Henk van Oers Dancer::Plugin::Lexicon uses Locale::Maketext::Lexicon to provide I18N functionality to your Dancer application. Translations are stored in PO or MO (compiled PO) gettext files in the "languages/" dir. You can generate or update your PO files by automatically extracting translatable strings from your code and templates with xgettext.pl. The user's preferred language can be auto-detected from their browser settings, and the current language is automatically stored in the user's session. Including "lang=$lang_tag" in the query string change the user's language.
Notes
Notes: svn path=/head/; revision=364581
Diffstat (limited to 'www/p5-Dancer-Plugin-Lexicon/Makefile')
-rw-r--r--www/p5-Dancer-Plugin-Lexicon/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-Dancer-Plugin-Lexicon/Makefile b/www/p5-Dancer-Plugin-Lexicon/Makefile
new file mode 100644
index 000000000000..1a58086652d0
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Lexicon/Makefile
@@ -0,0 +1,26 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-Lexicon
+PORTVERSION= 0.06
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DRTECH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Flexible I18N using Locale::Maketext::Lexicon for Dancer apps
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Dancer>=1.3118:${PORTSDIR}/www/p5-Dancer \
+ p5-Locale-Maketext-Lexicon>0:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
+ p5-Package-Stash>0:${PORTSDIR}/devel/p5-Package-Stash \
+ p5-PathTools>0:${PORTSDIR}/devel/p5-PathTools
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>