aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2012-07-22 14:43:53 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2012-07-22 14:43:53 +0000
commita3ce0a40d2b415fb02cf1c2245822d0b17e90784 (patch)
tree1b01fe0e33d35fb46e03cdefc1ae987feca65f1c /www/p5-Dancer
parente88bae9ae50970917bfb3fa6aef6b96ce7a55e0f (diff)
downloadports-a3ce0a40d2b415fb02cf1c2245822d0b17e90784.tar.gz
ports-a3ce0a40d2b415fb02cf1c2245822d0b17e90784.zip
- Upgrade to 1.3097.
Notes
Notes: svn path=/head/; revision=301337
Diffstat (limited to 'www/p5-Dancer')
-rw-r--r--www/p5-Dancer/Makefile16
-rw-r--r--www/p5-Dancer/distinfo4
-rw-r--r--www/p5-Dancer/files/patch-02_exceptions.t11
3 files changed, 15 insertions, 16 deletions
diff --git a/www/p5-Dancer/Makefile b/www/p5-Dancer/Makefile
index 80551b3a2979..6cddafb9de20 100644
--- a/www/p5-Dancer/Makefile
+++ b/www/p5-Dancer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Dancer
-PORTVERSION= 1.3095
+PORTVERSION= 1.3097
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:XSAWYERX
@@ -26,12 +26,22 @@ RUN_DEPENDS= \
p5-URI>=1.59:${PORTSDIR}/net/p5-URI \
p5-Try-Tiny>=0.09:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS:= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Clone>0:${PORTSDIR}/devel/p5-Clone \
+ p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-YAML>0:${PORTSDIR}/textproc/p5-YAML \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-HTTP-Parser-XS>0:${PORTSDIR}/www/p5-HTTP-Parser-XS \
+ p5-Template-Toolkit>0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-Test-Output>0:${PORTSDIR}/devel/p5-Test-Output
-OPTIONS= YAML "Enable YAML implementation in Perl" On
+OPTIONS_DEFINE= YAML
.include <bsd.port.options.mk>
-.if defined(WITH_YAML)
+.if ${PORT_OPTIONS:MYAML}
RUN_DEPENDS+= p5-YAML>=0.71:${PORTSDIR}/textproc/p5-YAML
.endif
diff --git a/www/p5-Dancer/distinfo b/www/p5-Dancer/distinfo
index 763c7a9848ac..b8745373c0d6 100644
--- a/www/p5-Dancer/distinfo
+++ b/www/p5-Dancer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Dancer-1.3095.tar.gz) = aeb74ae4f19185ded04f0efbf6f9a8421bef5600e56557a4d3814840bb741f5d
-SIZE (Dancer-1.3095.tar.gz) = 292225
+SHA256 (Dancer-1.3097.tar.gz) = 5a493069170fddeb16ff341828c7841f8c5f98eb13c2965fa8a8561f2a733bbf
+SIZE (Dancer-1.3097.tar.gz) = 294126
diff --git a/www/p5-Dancer/files/patch-02_exceptions.t b/www/p5-Dancer/files/patch-02_exceptions.t
deleted file mode 100644
index e9872da193b8..000000000000
--- a/www/p5-Dancer/files/patch-02_exceptions.t
+++ /dev/null
@@ -1,11 +0,0 @@
---- t/25_exceptions/02_exceptions.t.orig 2012-05-27 13:36:12.711337363 +0900
-+++ t/25_exceptions/02_exceptions.t 2012-05-27 13:36:35.595803613 +0900
-@@ -130,7 +130,7 @@
- };
- };
- ok(! $@);
-- is($e, 'wrong login (login was douglas)');
-+ like($e, qr/wrong login \(login was douglas\)/);
- # check stringification works in other cases
- ok($e eq 'wrong login (login was douglas)');
- ok('wrong login (login was douglas)' eq $e);