aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2012-05-27 07:50:24 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2012-05-27 07:50:24 +0000
commitda06eb63fcf3c97eb7c94153e5c5c6e7ec12875f (patch)
treebc7ac2e0763d4120355a4d4e600ac627614c7f11 /www/p5-Dancer
parentacf0d0a8c4ea430bc30f4c725268b8e3f8f813ba (diff)
downloadports-da06eb63fcf3c97eb7c94153e5c5c6e7ec12875f.tar.gz
ports-da06eb63fcf3c97eb7c94153e5c5c6e7ec12875f.zip
- Upgrade to 1.3095.
Notes
Notes: svn path=/head/; revision=297522
Diffstat (limited to 'www/p5-Dancer')
-rw-r--r--www/p5-Dancer/Makefile3
-rw-r--r--www/p5-Dancer/distinfo4
-rw-r--r--www/p5-Dancer/files/patch-02_exceptions.t11
-rw-r--r--www/p5-Dancer/pkg-plist2
4 files changed, 17 insertions, 3 deletions
diff --git a/www/p5-Dancer/Makefile b/www/p5-Dancer/Makefile
index ed900222b571..df3afdf94676 100644
--- a/www/p5-Dancer/Makefile
+++ b/www/p5-Dancer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Dancer
-PORTVERSION= 1.3093
+PORTVERSION= 1.3095
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:XSAWYERX
@@ -40,6 +40,7 @@ PERL_CONFIGURE= yes
MAN1= dancer.1
MAN3= Dancer.3 \
Dancer::Config.3 \
+ Dancer::Config::Object.3 \
Dancer::Cookbook.3 \
Dancer::Cookie.3 \
Dancer::Cookies.3 \
diff --git a/www/p5-Dancer/distinfo b/www/p5-Dancer/distinfo
index 259d8247c2e2..763c7a9848ac 100644
--- a/www/p5-Dancer/distinfo
+++ b/www/p5-Dancer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Dancer-1.3093.tar.gz) = 099ee41e9caead7a4d701af944a13efcef11088d5ceea124b03cc508ffc96695
-SIZE (Dancer-1.3093.tar.gz) = 287706
+SHA256 (Dancer-1.3095.tar.gz) = aeb74ae4f19185ded04f0efbf6f9a8421bef5600e56557a4d3814840bb741f5d
+SIZE (Dancer-1.3095.tar.gz) = 292225
diff --git a/www/p5-Dancer/files/patch-02_exceptions.t b/www/p5-Dancer/files/patch-02_exceptions.t
new file mode 100644
index 000000000000..e9872da193b8
--- /dev/null
+++ b/www/p5-Dancer/files/patch-02_exceptions.t
@@ -0,0 +1,11 @@
+--- t/25_exceptions/02_exceptions.t.orig 2012-05-27 13:36:12.711337363 +0900
++++ t/25_exceptions/02_exceptions.t 2012-05-27 13:36:35.595803613 +0900
+@@ -130,7 +130,7 @@
+ };
+ };
+ ok(! $@);
+- is($e, 'wrong login (login was douglas)');
++ like($e, qr/wrong login \(login was douglas\)/);
+ # check stringification works in other cases
+ ok($e eq 'wrong login (login was douglas)');
+ ok('wrong login (login was douglas)' eq $e);
diff --git a/www/p5-Dancer/pkg-plist b/www/p5-Dancer/pkg-plist
index e07cf48f9827..68a7b7ee6294 100644
--- a/www/p5-Dancer/pkg-plist
+++ b/www/p5-Dancer/pkg-plist
@@ -3,6 +3,7 @@ bin/dancer
%%SITE_PERL%%/Dancer.pm
%%SITE_PERL%%/Dancer/App.pm
%%SITE_PERL%%/Dancer/Config.pm
+%%SITE_PERL%%/Dancer/Config/Object.pm
%%SITE_PERL%%/Dancer/Continuation.pm
%%SITE_PERL%%/Dancer/Continuation/Halted.pm
%%SITE_PERL%%/Dancer/Continuation/Route.pm
@@ -91,5 +92,6 @@ bin/dancer
@dirrm %%SITE_PERL%%/Dancer/Development
@dirrm %%SITE_PERL%%/Dancer/Continuation/Route
@dirrm %%SITE_PERL%%/Dancer/Continuation
+@dirrm %%SITE_PERL%%/Dancer/Config
@dirrm %%SITE_PERL%%/Dancer
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer