aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Declare/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-10-08 10:59:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-10-08 10:59:20 +0000
commit940beb0edecbeedfefccbae8550695003eb0754b (patch)
tree8a67926a19fec3fda4aa7afd9079d1c4a39fd037 /www/p5-HTML-Declare/Makefile
parent9d58902203f3891279595744cafc304580d7040a (diff)
downloadports-940beb0edecbeedfefccbae8550695003eb0754b.tar.gz
ports-940beb0edecbeedfefccbae8550695003eb0754b.zip
- Add p5-HTML-Declare 2.4
HTML::Declare is a very simple micro language to generate HTML. WWW: http://search.cpan.org/dist/HTML-Declare/ Submitted by: sunpoet (myself) Approved by: pgollucci (mentor)
Notes
Notes: svn path=/head/; revision=262612
Diffstat (limited to 'www/p5-HTML-Declare/Makefile')
-rw-r--r--www/p5-HTML-Declare/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-HTML-Declare/Makefile b/www/p5-HTML-Declare/Makefile
new file mode 100644
index 000000000000..e25daf6f7324
--- /dev/null
+++ b/www/p5-HTML-Declare/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-HTML-Declare
+# Date created: 2010-10-06
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Declare
+PORTVERSION= 2.4
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A very simple micro language to generate HTML
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Declare.3
+PLIST_FILES= %%SITE_PERL%%/HTML/Declare.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Declare/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Declare
+
+.include <bsd.port.mk>