aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Lint
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-12-27 11:38:10 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-12-27 11:38:10 +0000
commit3bc1f9017cf00623802a7e47feb21afe5bc3756d (patch)
tree6c13a5556b3f3184fb02ca813a6a335f93417939 /www/p5-HTML-Lint
parenta1d851e348fa5b19685cb6d739296caa25a24656 (diff)
downloadports-3bc1f9017cf00623802a7e47feb21afe5bc3756d.tar.gz
ports-3bc1f9017cf00623802a7e47feb21afe5bc3756d.zip
Add www/p5-HTML-Lint 2.02, a Perl module that checks for HTML errors in
a string or file.
Notes
Notes: svn path=/head/; revision=152188
Diffstat (limited to 'www/p5-HTML-Lint')
-rw-r--r--www/p5-HTML-Lint/Makefile36
-rw-r--r--www/p5-HTML-Lint/distinfo3
-rw-r--r--www/p5-HTML-Lint/pkg-descr6
-rw-r--r--www/p5-HTML-Lint/pkg-plist12
4 files changed, 57 insertions, 0 deletions
diff --git a/www/p5-HTML-Lint/Makefile b/www/p5-HTML-Lint/Makefile
new file mode 100644
index 000000000000..0cca36b73535
--- /dev/null
+++ b/www/p5-HTML-Lint/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: www/p5-HTML-Lint
+# Date created: 27 December 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Lint
+PORTVERSION= 2.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= HTML::Lint - check for HTML errors in a string or file
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Lint.3 \
+ HTML::Lint::Error.3 \
+ HTML::Lint::HTML4.3 \
+ Test::HTML::Lint.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-Lint/distinfo b/www/p5-HTML-Lint/distinfo
new file mode 100644
index 000000000000..25ea7a374a38
--- /dev/null
+++ b/www/p5-HTML-Lint/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Lint-2.02.tar.gz) = f08241fbe2473d7542be5ef660ced6e3
+SHA256 (HTML-Lint-2.02.tar.gz) = 517caf805cf792fdbd44ffacc57ccbf57a45709e987f49fee881886dfa6c6395
+SIZE (HTML-Lint-2.02.tar.gz) = 22629
diff --git a/www/p5-HTML-Lint/pkg-descr b/www/p5-HTML-Lint/pkg-descr
new file mode 100644
index 000000000000..ed36b340ce1a
--- /dev/null
+++ b/www/p5-HTML-Lint/pkg-descr
@@ -0,0 +1,6 @@
+HTML::Lint - check for HTML errors in a string or file.
+
+HTML::Lint also comes with a wrapper program called weblint that handles
+linting from the command line.
+
+WWW: http://search.cpan.org/dist/HTML-Lint/
diff --git a/www/p5-HTML-Lint/pkg-plist b/www/p5-HTML-Lint/pkg-plist
new file mode 100644
index 000000000000..88cfa1d8a011
--- /dev/null
+++ b/www/p5-HTML-Lint/pkg-plist
@@ -0,0 +1,12 @@
+bin/weblint
+%%SITE_PERL%%/HTML/Lint.pm
+%%SITE_PERL%%/HTML/Lint/Error.pm
+%%SITE_PERL%%/HTML/Lint/HTML4.pm
+%%SITE_PERL%%/Test/HTML/Lint.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Lint/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Lint 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML/Lint 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true