aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Prototype
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-05-07 20:08:36 +0000
committerLars Thegler <lth@FreeBSD.org>2005-05-07 20:08:36 +0000
commit3577ca83ea009cb35c1bfa90b4df3d99755a8c91 (patch)
tree553f864ae20a6f0fc7e38892c0940d960effc99b /www/p5-HTML-Prototype
parent5adcfd71780fa1560350a221bd89ce701c4a16d3 (diff)
downloadports-3577ca83ea009cb35c1bfa90b4df3d99755a8c91.tar.gz
ports-3577ca83ea009cb35c1bfa90b4df3d99755a8c91.zip
Add p5-HTML-Prototype 1.23, generate HTML and Javascript for the
Prototype library.
Notes
Notes: svn path=/head/; revision=134798
Diffstat (limited to 'www/p5-HTML-Prototype')
-rw-r--r--www/p5-HTML-Prototype/Makefile27
-rw-r--r--www/p5-HTML-Prototype/distinfo2
-rw-r--r--www/p5-HTML-Prototype/pkg-descr8
-rw-r--r--www/p5-HTML-Prototype/pkg-plist4
4 files changed, 41 insertions, 0 deletions
diff --git a/www/p5-HTML-Prototype/Makefile b/www/p5-HTML-Prototype/Makefile
new file mode 100644
index 000000000000..77b61dc6571b
--- /dev/null
+++ b/www/p5-HTML-Prototype/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-HTML-Prototype
+# Date created: 07 May 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Prototype
+PORTVERSION= 1.23
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Generate HTML and Javascript for the Prototype library
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+CONFIGURE_ARGS+= create_packlist=0
+
+MAN3= HTML::Prototype.3 \
+ HTML::Prototype::Js.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Prototype/distinfo b/www/p5-HTML-Prototype/distinfo
new file mode 100644
index 000000000000..714cb8f40292
--- /dev/null
+++ b/www/p5-HTML-Prototype/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTML-Prototype-1.23.tar.gz) = 9def8a9079f39a88377a7a1ea089d50a
+SIZE (HTML-Prototype-1.23.tar.gz) = 10810
diff --git a/www/p5-HTML-Prototype/pkg-descr b/www/p5-HTML-Prototype/pkg-descr
new file mode 100644
index 000000000000..99d62d293d30
--- /dev/null
+++ b/www/p5-HTML-Prototype/pkg-descr
@@ -0,0 +1,8 @@
+Some code generators for Prototype, the famous JavaScript OO library.
+This library allows you to do Ajax without writing lots of javascript
+code.
+
+This is mostly a port of the Ruby on Rails helper tags for JavaScript
+for use in Catalyst.
+
+WWW: http://search.cpan.org/dist/HTML-Prototype
diff --git a/www/p5-HTML-Prototype/pkg-plist b/www/p5-HTML-Prototype/pkg-plist
new file mode 100644
index 000000000000..30eb015fe6dd
--- /dev/null
+++ b/www/p5-HTML-Prototype/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/HTML/Prototype.pm
+%%SITE_PERL%%/HTML/Prototype/Js.pm
+@unexec rmdir %D/%%SITE_PERL%%/HTML/Prototype 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true