aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-SimpleLinkExtor
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2004-07-15 11:16:12 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2004-07-15 11:16:12 +0000
commitb496137ddf692e75acc739988a87c4b50aff67eb (patch)
treec70408627082ab65e455f85fcffd5a0cacfd7cb5 /www/p5-HTML-SimpleLinkExtor
parente0393ad66ec6e15e782930cb0d5ce705f4d7acfb (diff)
downloadports-b496137ddf692e75acc739988a87c4b50aff67eb.tar.gz
ports-b496137ddf692e75acc739988a87c4b50aff67eb.zip
This is a simple HTML link extractor
Notes
Notes: svn path=/head/; revision=113705
Diffstat (limited to 'www/p5-HTML-SimpleLinkExtor')
-rw-r--r--www/p5-HTML-SimpleLinkExtor/Makefile26
-rw-r--r--www/p5-HTML-SimpleLinkExtor/distinfo2
-rw-r--r--www/p5-HTML-SimpleLinkExtor/pkg-descr5
-rw-r--r--www/p5-HTML-SimpleLinkExtor/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/www/p5-HTML-SimpleLinkExtor/Makefile b/www/p5-HTML-SimpleLinkExtor/Makefile
new file mode 100644
index 000000000000..f014d6deb5de
--- /dev/null
+++ b/www/p5-HTML-SimpleLinkExtor/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-HTML-SimpleLinkExtor
+# Date created: 15 July 2004
+# Whom: Andrey Chernov <ache@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-SimpleLinkExtor
+PORTVERSION= 1.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= This is a simple HTML link extractor
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::SimpleLinkExtor.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-SimpleLinkExtor/distinfo b/www/p5-HTML-SimpleLinkExtor/distinfo
new file mode 100644
index 000000000000..0446108814d7
--- /dev/null
+++ b/www/p5-HTML-SimpleLinkExtor/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTML-SimpleLinkExtor-1.06.tar.gz) = b86290d5f29049d198c02ad76f80ee5d
+SIZE (HTML-SimpleLinkExtor-1.06.tar.gz) = 4827
diff --git a/www/p5-HTML-SimpleLinkExtor/pkg-descr b/www/p5-HTML-SimpleLinkExtor/pkg-descr
new file mode 100644
index 000000000000..e5d80f73857e
--- /dev/null
+++ b/www/p5-HTML-SimpleLinkExtor/pkg-descr
@@ -0,0 +1,5 @@
+This is a simple HTML link extractor designed for the person who does
+not want to deal with the intricacies of "HTML::Parser" or the de-ref-
+erencing needed to get links out of "HTML::LinkExtor".
+
+WWW: http://search.cpan.org/dist/HTML-SimpleLinkExtor/
diff --git a/www/p5-HTML-SimpleLinkExtor/pkg-plist b/www/p5-HTML-SimpleLinkExtor/pkg-plist
new file mode 100644
index 000000000000..373f2b238c9e
--- /dev/null
+++ b/www/p5-HTML-SimpleLinkExtor/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTML/SimpleLinkExtor.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/SimpleLinkExtor/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/SimpleLinkExtor
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true