aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-TableParser
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-18 19:39:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-18 19:39:22 +0000
commit72e8003e70440c1eda7ffbc27bdb8b234ddfcfc2 (patch)
tree59f6cfce39d2bbdbc2fcabc6f96dca1c8968ec9a /www/p5-HTML-TableParser
parent87f505ca62df6de29a3acd335b6235412256645c (diff)
downloadports-72e8003e70440c1eda7ffbc27bdb8b234ddfcfc2.tar.gz
ports-72e8003e70440c1eda7ffbc27bdb8b234ddfcfc2.zip
HTML::TableParser uses HTML::Parser to extract data from an HTML table. The
data is returned via a series of user defined callback functions or methods. Specific tables may be selected either by a matching a unique table id or by matching against the column names. Multiple (even nested) tables may be parsed in a document in one pass. WWW: http://search.cpan.org/dist/HTML-TableParser/ PR: ports/101998 Submitted by: chinsan <chinsan.tw(at)gmail.com> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=170955
Diffstat (limited to 'www/p5-HTML-TableParser')
-rw-r--r--www/p5-HTML-TableParser/Makefile31
-rw-r--r--www/p5-HTML-TableParser/distinfo3
-rw-r--r--www/p5-HTML-TableParser/pkg-descr7
-rw-r--r--www/p5-HTML-TableParser/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/www/p5-HTML-TableParser/Makefile b/www/p5-HTML-TableParser/Makefile
new file mode 100644
index 000000000000..1b916f052845
--- /dev/null
+++ b/www/p5-HTML-TableParser/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-HTML-TableParser
+# Date created: 2006/08/14
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-TableParser
+PORTVERSION= 0.34
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Extract data from an HTML table
+
+BUILD_DEPENDS= p5-HTML-Parser>=3.34:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::TableParser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.x or later due to Unicode escapes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-TableParser/distinfo b/www/p5-HTML-TableParser/distinfo
new file mode 100644
index 000000000000..327c55203ffd
--- /dev/null
+++ b/www/p5-HTML-TableParser/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-TableParser-0.34.tar.gz) = 25594389d4678056bb7fc34520e462e4
+SHA256 (HTML-TableParser-0.34.tar.gz) = 6d2f5f73c6b94a196e299c8d5f8a71b6ae036a17232a087ebbef431c3053d4ae
+SIZE (HTML-TableParser-0.34.tar.gz) = 47156
diff --git a/www/p5-HTML-TableParser/pkg-descr b/www/p5-HTML-TableParser/pkg-descr
new file mode 100644
index 000000000000..b7c26c7dd762
--- /dev/null
+++ b/www/p5-HTML-TableParser/pkg-descr
@@ -0,0 +1,7 @@
+HTML::TableParser uses HTML::Parser to extract data from an HTML table. The
+data is returned via a series of user defined callback functions or methods.
+Specific tables may be selected either by a matching a unique table id or by
+matching against the column names. Multiple (even nested) tables may be
+parsed in a document in one pass.
+
+WWW: http://search.cpan.org/dist/HTML-TableParser/
diff --git a/www/p5-HTML-TableParser/pkg-plist b/www/p5-HTML-TableParser/pkg-plist
new file mode 100644
index 000000000000..de8952771dc5
--- /dev/null
+++ b/www/p5-HTML-TableParser/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/TableParser/.packlist
+%%SITE_PERL%%/HTML/TableParser.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/TableParser
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML