aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-WikiConverter-Oddmuse/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-07-21 10:12:58 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-07-21 10:12:58 +0000
commit91557291489e7475cc659a16ca6fb9925e8e7308 (patch)
tree7643b9ab8e778de14ef335c37076e8ec6c710ea3 /www/p5-HTML-WikiConverter-Oddmuse/Makefile
parentfa7ccb4a611567ef78dcedc49fa60ff4c3e20129 (diff)
downloadports-91557291489e7475cc659a16ca6fb9925e8e7308.tar.gz
ports-91557291489e7475cc659a16ca6fb9925e8e7308.zip
This module contains rules for converting HTML into Oddmuse markup. See
HTML::WikiConverter for additional usage details. WWW: http://search.cpan.org/dist/HTML-WikiConverter-Oddmuse/ Author: David J. Iberri <diberri@yahoo.com> PR: ports/100643 Submitted by: chinsan <chinsan.tw at gmail.com>
Notes
Notes: svn path=/head/; revision=168357
Diffstat (limited to 'www/p5-HTML-WikiConverter-Oddmuse/Makefile')
-rw-r--r--www/p5-HTML-WikiConverter-Oddmuse/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-HTML-WikiConverter-Oddmuse/Makefile b/www/p5-HTML-WikiConverter-Oddmuse/Makefile
new file mode 100644
index 000000000000..640c345f2875
--- /dev/null
+++ b/www/p5-HTML-WikiConverter-Oddmuse/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-HTML-WikiConverter-Oddmuse
+# Date created: 2006/06/27
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-WikiConverter-Oddmuse
+PORTVERSION= 0.52
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Convert HTML to Oddmuse markup
+
+BUILD_DEPENDS= p5-HTML-WikiConverter>=0.60:${PORTSDIR}/www/p5-HTML-WikiConverter \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::WikiConverter::Oddmuse.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.x or later due to Unicode escapes
+.endif
+
+.include <bsd.port.post.mk>