aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Recorder/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-04-01 16:08:26 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-04-01 16:08:26 +0000
commitda7bf5889ab68159ac3abaac4b3d703aae549716 (patch)
tree4e119c0d7d602f60f14449fef33e414ec04bddc0 /www/p5-HTTP-Recorder/Makefile
parent4c3391b5d45b93dfb4726a9986bb8af324129bdf (diff)
downloadports-da7bf5889ab68159ac3abaac4b3d703aae549716.tar.gz
ports-da7bf5889ab68159ac3abaac4b3d703aae549716.zip
Add p5-HTTP-Recorder 0.03.01, record interaction with websites.
Notes
Notes: svn path=/head/; revision=105887
Diffstat (limited to 'www/p5-HTTP-Recorder/Makefile')
-rw-r--r--www/p5-HTTP-Recorder/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-HTTP-Recorder/Makefile b/www/p5-HTTP-Recorder/Makefile
new file mode 100644
index 000000000000..220d22c0b5bf
--- /dev/null
+++ b/www/p5-HTTP-Recorder/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-HTTP-Recorder
+# Date created: 1 April 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Recorder
+PORTVERSION= 0.03.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/L/LE/LEIRA
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/_\1/}
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Record interaction with websites
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Recorder.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/;' \
+ -e '$$_ = "" if /use warnings/;' \
+ ${WRKSRC}/lib/HTTP/Recorder.pm \
+ ${WRKSRC}/lib/HTTP/Recorder/Logger.pm
+.endif
+
+.include <bsd.port.post.mk>