aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Recorder
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-10-05 11:24:31 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-10-05 11:24:31 +0000
commit29f8ef3a8cf2339e8e1088bb597c315d9374c5d8 (patch)
treec73a04c89712899380e8f658e232ec6c539c9d8b /www/p5-HTTP-Recorder
parent9369f59a05e76037ead9538b3438d9bf7e23d82b (diff)
downloadports-29f8ef3a8cf2339e8e1088bb597c315d9374c5d8.tar.gz
ports-29f8ef3a8cf2339e8e1088bb597c315d9374c5d8.zip
Fix a long-standing bug which has not been fixed upstream for years.
Bump portrevision. PR: 138349 Submitted by: Ashish SHUKLA <wahjava@gmail.com>
Notes
Notes: svn path=/head/; revision=242487
Diffstat (limited to 'www/p5-HTTP-Recorder')
-rw-r--r--www/p5-HTTP-Recorder/Makefile4
-rw-r--r--www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm25
2 files changed, 29 insertions, 0 deletions
diff --git a/www/p5-HTTP-Recorder/Makefile b/www/p5-HTTP-Recorder/Makefile
index 44c32741d34b..6e189df4f9db 100644
--- a/www/p5-HTTP-Recorder/Makefile
+++ b/www/p5-HTTP-Recorder/Makefile
@@ -7,6 +7,7 @@
PORTNAME= HTTP-Recorder
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/L/LE/LEIRA
@@ -24,4 +25,7 @@ PERL_CONFIGURE= yes
MAN3= HTTP::Recorder.3
+post-patch:
+ ${RM} -f ${WRKSRC}/lib/HTTP/Recorder.pm.orig
+
.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm b/www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm
new file mode 100644
index 000000000000..9227e5f7a31b
--- /dev/null
+++ b/www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- lib/HTTP/Recorder.pm.orig
++++ lib/HTTP/Recorder.pm
+@@ -344,12 +344,13 @@
+ # get rid of the arguments we added
+ my $prefix = $self->{prefix};
+
+- for my $key ($content->query_param) {
+- if ($key =~ /^$prefix-/) {
+- $content->query_param_delete($key);
+- }
+- }
+- return $content;
++ $content =~ s/$prefix-(.*?)\?(.*?)&//g;
++ $content =~ s/$prefix-(.*?)&//g;
++ $content =~ s/$prefix-(.*?)$//g;
++ $content =~ s/&$//g;
++ $content =~ s/\?$//g;
++
++ return $content;
+ }
+
+ sub extract_values {