aboutsummaryrefslogtreecommitdiff
path: root/www/p5-IMDB-Film
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-02 03:20:18 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-02 03:20:18 +0000
commitdc174bdbe2026f98258aa5544d6b7609388b8bc5 (patch)
treed59003e1eaa631d80329a660f3f36cbca320a7d3 /www/p5-IMDB-Film
parent78fe3a05c5a5e43003d187b7705da25cdc321100 (diff)
downloadports-dc174bdbe2026f98258aa5544d6b7609388b8bc5.tar.gz
ports-dc174bdbe2026f98258aa5544d6b7609388b8bc5.zip
Add p5-IMDB-Film 0.22, OO Perl interface to the movies database IMDB.
PR: ports/101215 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=169426
Diffstat (limited to 'www/p5-IMDB-Film')
-rw-r--r--www/p5-IMDB-Film/Makefile35
-rw-r--r--www/p5-IMDB-Film/distinfo3
-rw-r--r--www/p5-IMDB-Film/pkg-descr4
-rw-r--r--www/p5-IMDB-Film/pkg-plist8
4 files changed, 50 insertions, 0 deletions
diff --git a/www/p5-IMDB-Film/Makefile b/www/p5-IMDB-Film/Makefile
new file mode 100644
index 000000000000..8f5024a26ff6
--- /dev/null
+++ b/www/p5-IMDB-Film/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-IMDB-Film
+# Date created: 2006-08-02
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IMDB-Film
+PORTVERSION= 0.22
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/S/ST/STEPANOV
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= OO Perl interface to the movies database IMDB
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/Cache/FileCache.pm:${PORTSDIR}/devel/p5-Cache-Cache \
+ ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
+ p5-HTML-Parser>=3.34:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-libwww>=5.800:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= </dev/null
+
+MAN3= IMDB::BaseClass.3 IMDB::Film.3 IMDB::Persons.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from many ports
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-IMDB-Film/distinfo b/www/p5-IMDB-Film/distinfo
new file mode 100644
index 000000000000..7836bcde48a6
--- /dev/null
+++ b/www/p5-IMDB-Film/distinfo
@@ -0,0 +1,3 @@
+MD5 (IMDB-Film-0.22.tar.gz) = 3a3906237fe7ec32a587405fdc74be0b
+SHA256 (IMDB-Film-0.22.tar.gz) = c88864ccdd66f20211e5ba9bf3096b2f9a5d1fa21fe34eeb6abf07e4b0594cf4
+SIZE (IMDB-Film-0.22.tar.gz) = 48094
diff --git a/www/p5-IMDB-Film/pkg-descr b/www/p5-IMDB-Film/pkg-descr
new file mode 100644
index 000000000000..2648e8c29a4b
--- /dev/null
+++ b/www/p5-IMDB-Film/pkg-descr
@@ -0,0 +1,4 @@
+IMDB::Film is an object-oriented interface to the IMDB. You can use
+that module to retrieve information about film: title, year, plot etc.
+
+WWW: http://search.cpan.org/dist/IMDB-Film/
diff --git a/www/p5-IMDB-Film/pkg-plist b/www/p5-IMDB-Film/pkg-plist
new file mode 100644
index 000000000000..3d0c810ceb37
--- /dev/null
+++ b/www/p5-IMDB-Film/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IMDB/Film/.packlist
+%%SITE_PERL%%/IMDB/Film.pm
+%%SITE_PERL%%/IMDB/BaseClass.pm
+%%SITE_PERL%%/IMDB/Persons.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IMDB/Film
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IMDB
+@dirrmtry %%SITE_PERL%%/IMDB