aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Jifty
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /www/p5-Jifty
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'www/p5-Jifty')
-rw-r--r--www/p5-Jifty/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/p5-Jifty/Makefile b/www/p5-Jifty/Makefile
index dc93fd5280b4..8595b87044c2 100644
--- a/www/p5-Jifty/Makefile
+++ b/www/p5-Jifty/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Jifty
PORTVERSION= 1.10518
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:SARTAK
@@ -12,7 +12,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Jifty -- Just Do It -- Yet another web framework
-BUILD_DEPENDS= p5-App-CLI>=0.03:${PORTSDIR}/devel/p5-App-CLI \
+BUILD_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-App-CLI>=0.03:${PORTSDIR}/devel/p5-App-CLI \
p5-CGI-Cookie-Splitter>=0:${PORTSDIR}/www/p5-CGI-Cookie-Splitter \
p5-CGI-Emulate-PSGI>=0.06:${PORTSDIR}/www/p5-CGI-Emulate-PSGI \
p5-CSS-Squish>=0.05:${PORTSDIR}/textproc/p5-CSS-Squish \
@@ -86,8 +87,7 @@ BUILD_DEPENDS= p5-App-CLI>=0.03:${PORTSDIR}/devel/p5-App-CLI \
p5-XML-XPath>0:${PORTSDIR}/textproc/p5-XML-XPath \
p5-YAML>=0.35:${PORTSDIR}/textproc/p5-YAML \
p5-YAML-Syck>=0.71:${PORTSDIR}/textproc/p5-YAML-Syck \
- p5-libwww>0:${PORTSDIR}/www/p5-libwww \
- p5-version>0:${PORTSDIR}/devel/p5-version
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Base>=0.44:${PORTSDIR}/devel/p5-Test-Base \
p5-Test-HTTP-Server-Simple>=0.02:${PORTSDIR}/www/p5-Test-HTTP-Server-Simple \